From: Marek Olšák <marek.ol...@amd.com>

Cc: 18.0 17.3 17.2 <mesa-sta...@lists.freedesktop.org>
---
 configure.ac | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/configure.ac b/configure.ac
index 621dc32..e29ce68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2601,20 +2601,27 @@ if test -n "$with_gallium_drivers"; then
                 radeon_llvm_check $LLVM_REQUIRED_R600 "r600"
 
                 llvm_add_component "asmparser" "r600"
                 llvm_add_component "bitreader" "r600"
             fi
             ;;
         xradeonsi)
             HAVE_GALLIUM_RADEONSI=yes
             PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED 
libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
             PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED 
libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
+
+            # Blacklist libdrm_amdgpu 2.4.90 because it breaks older radeonsi
+            libdrm_version=`pkg-config libdrm_amdgpu --modversion`
+            if test "x$libdrm_version" = x2.4.90; then
+                AC_MSG_ERROR([radeonsi can't use libdrm 2.4.90 due to a 
compatibility issue. Use a newer or older version.])
+            fi
+
             require_libdrm "radeonsi"
             radeon_llvm_check $LLVM_REQUIRED_RADEONSI "radeonsi"
             if test "x$enable_egl" = xyes; then
                 require_basic_egl "radeonsi"
             fi
             ;;
         xnouveau)
             HAVE_GALLIUM_NOUVEAU=yes
             PKG_CHECK_MODULES([NOUVEAU], [libdrm >= $LIBDRM_NOUVEAU_REQUIRED 
libdrm_nouveau >= $LIBDRM_NOUVEAU_REQUIRED])
             require_libdrm "nouveau"
-- 
2.7.4

_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to