> -----Original Message----- > From: Maupin, Chase > Sent: Thursday, March 21, 2013 7:12 AM > To: Cooper Jr., Franklin; [email protected] > Subject: RE: [meta-arago] [PATCH 09/17] wpa-supplicant: Split recipe > > > -----Original Message----- > > From: [email protected] [mailto:meta-arago- > > [email protected]] On Behalf Of Cooper Jr., Franklin > > Sent: Tuesday, March 19, 2013 9:05 PM > > To: [email protected] > > Cc: Cooper Jr., Franklin > > Subject: [meta-arago] [PATCH 09/17] wpa-supplicant: Split recipe > > > > * Split recipe to allow multiple versions of wpa-supplicant to exist. > > * Rename recipe to match the actual version of the TI modified > > wpa-supplicant. > > > > Signed-off-by: Franklin S. Cooper Jr <[email protected]> > > --- > > .../defconfig | 0 > > .../{wpa-supplicant_git.bb => wpa-supplicant.inc} | 15 +++++- > > --------- > > .../wpa-supplicant/wpa-supplicant_r5.sp4.01.bb | 13 > > +++++++++++++ > > 3 files changed, 18 insertions(+), 10 deletions(-) rename > > meta-arago-extras/recipes-connectivity/wpa- > > supplicant/{wpa-supplicant => wpa-supplicant-r5.sp4.01}/defconfig > > (100%) > > rename meta-arago-extras/recipes-connectivity/wpa- > > supplicant/{wpa-supplicant_git.bb => wpa-supplicant.inc} (91%) create > > mode 100644 meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant_r5.sp4.01.bb > > > > diff --git a/meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant/defconfig b/meta-arago-extras/recipes- > > connectivity/wpa-supplicant/wpa-supplicant-r5.sp4.01/defconfig > > similarity index 100% > > rename from meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant/defconfig > > rename to meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant-r5.sp4.01/defconfig > > diff --git a/meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant_git.bb b/meta-arago-extras/recipes- > > connectivity/wpa-supplicant/wpa-supplicant.inc > > similarity index 91% > > rename from meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant_git.bb > > rename to meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant.inc > > index 927a556..21ec6a3 100644 > > --- a/meta-arago-extras/recipes-connectivity/wpa-supplicant/wpa- > > supplicant_git.bb > > +++ b/meta-arago-extras/recipes-connectivity/wpa-supplicant/wpa- > > supplicant.inc > > @@ -5,10 +5,7 @@ DESCRIPTION = "A Client for Wi-Fi Protected Access > > (WPA)." > > HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/" > > BUGTRACKER = "http://hostap.epitest.fi/bugz/" > > SECTION = "network" > > -LICENSE = "GPLv2 | BSD" > > -LIC_FILES_CHKSUM = > > "file://../COPYING;md5=ab87f20cd7e8c0d0a6539b34d3791d0e \ > > - > > file://../README;md5=5cb758942d25f6f61fd4ac388fd446fa \ > > - > > file://wpa_supplicant.c;beginline=1;endline=17;md5=8835156c8ab8ca > > d6356ec7f39ebe3aba" > > + > > DEPENDS = "gnutls dbus libnl openssl > > ${@base_contains("COMBINED_FEATURES", "madwifi", "madwifi-ng", > "",d)}" > > RRECOMMENDS_${PN} = "wpa-supplicant-passphrase wpa-supplicant- cli" > > > > @@ -16,22 +13,19 @@ RRECOMMENDS_${PN} = "wpa-supplicant- > passphrase > > wpa-supplicant-cli" > > # wpa-supplicant the DEFAULT_PREFERENCE will be set to -1. > > DEFAULT_PREFERENCE = "-1" > > > > -SRCREV = "ol_R5.SP4.01" > > -PR = "r3+gitr${SRCPV}" > > -# Add ti to the PV to indicate that this is a TI modify version of > > wpa-supplicant. > > -PV = "2.0-devel-ti" > > +PR = "r4" > > > > SRC_URI = "git://github.com/TI-OpenLink/hostap.git;protocol=git > > \ > > file://defconfig \ > > file://defaults-sane \ > > file://wpa-supplicant.sh \ > > - file://kill_wpa_supplicant.sh \ > > file://wpa_supplicant.conf \ > > file://wpa_supplicant.conf-sane \ > > file://99_wpa_supplicant \ > > file://wpa_supplicant.conf \ > > file://fi.epitest.hostap.WPASupplicant.service \ > > file://fi.w1.wpa_supplicant1.service \ > > + file://kill_wpa_supplicant.sh \ > > Why the re-order Not sure why things got reordered. I ended up moving kill_wpa_supplicant to its own recipe so this issue is fixed in my updated patches. > > > " > > > > S = "${WORKDIR}/git/wpa_supplicant" > > @@ -54,7 +48,6 @@ do_install () { > > install -m 755 wpa_supplicant ${D}${sbindir} > > install -m 755 wpa_passphrase ${D}${sbindir} > > install -m 755 wpa_cli ${D}${sbindir} > > - install -m 755 ${WORKDIR}/kill_wpa_supplicant.sh > > ${D}${sbindir} > > > > install -d ${D}${docdir}/wpa_supplicant > > install -m 644 README ${WORKDIR}/wpa_supplicant.conf > > ${D}${docdir}/wpa_supplicant @@ -93,6 +86,8 @@ do_install () { > > install -m 644 ${WORKDIR}/wpa_supplicant.conf ${D}/etc > > install -m 644 > > ${WORKDIR}/fi.epitest.hostap.WPASupplicant.service > > ${D}/usr/share/dbus-1/system-services > > install -m 644 ${WORKDIR}/fi.w1.wpa_supplicant1.service > > ${D}/usr/share/dbus-1/system-services > > + > > + install -m 755 ${WORKDIR}/kill_wpa_supplicant.sh > > ${D}${sbindir} > > Same question, why the re-order? > > > } > > > > pkg_postinst_wpa-supplicant () { > > diff --git a/meta-arago-extras/recipes-connectivity/wpa- > > supplicant/wpa-supplicant_r5.sp4.01.bb b/meta-arago- > > extras/recipes-connectivity/wpa-supplicant/wpa- > > supplicant_r5.sp4.01.bb > > new file mode 100644 > > index 0000000..e23f3df > > --- /dev/null > > +++ b/meta-arago-extras/recipes-connectivity/wpa-supplicant/wpa- > > supplicant_r5.sp4.01.bb > > @@ -0,0 +1,13 @@ > > +# This is a TI specific version of the wpa-supplicant recipe for > > use with the > > +# wl12xx wlan and bluetooth module. > > + > > +require wpa-supplicant.inc > > + > > +LICENSE = "GPLv2 | BSD" > > +LIC_FILES_CHKSUM = > > "file://../COPYING;md5=ab87f20cd7e8c0d0a6539b34d3791d0e \ > > + > > file://../README;md5=5cb758942d25f6f61fd4ac388fd446fa \ > > + > > file://wpa_supplicant.c;beginline=1;endline=17;md5=8835156c8ab8ca > > d6356ec7f39ebe3aba" > > + > > + > > +SRCREV = "ol_R5.SP4.01" > > +PR_append = "-a+gitr${SRCPV}" > > Question about the PR append consistency with other recipes. Same as > previous feedback, do you need the "-" or just append the "a"? > My recipes with PR_append usually includes the dash. I made the changes to recipes that have MACHINE_KERNEL_PR since you mentioned that is the style used in meta-ti. But in meta-arago usually the dash is added and in some instances a dot is used. I am going to leave the dash as is for now but I don't mind creating patch later on that uses 1 particular append style for all recipes/appends in meta-arago. > > -- > > 1.7.0.4 > > > > _______________________________________________ > > meta-arago mailing list > > [email protected] > > http://arago-project.org/cgi-bin/mailman/listinfo/meta-arago _______________________________________________ meta-arago mailing list [email protected] http://arago-project.org/cgi-bin/mailman/listinfo/meta-arago
