On 04/15/2013 01:15 PM, Otavio Salvador wrote:
On Mon, Apr 15, 2013 at 12:30 PM, Daiane Angolini
<[email protected]> wrote:
On 04/15/2013 08:52 AM, Otavio Salvador wrote:

The Xorg Vivante driver has a hardcoded module name as 'vivante_dri'
so we need to rename it for full Xorg acceleration to work.

Signed-off-by: Otavio Salvador <[email protected]>
---
Changes in v3: None
Changes in v2: None

   recipes-graphics/xorg-driver/xf86-dri-vivante_1.1.0.bb | 4 ++++
   1 file changed, 4 insertions(+)

diff --git a/recipes-graphics/xorg-driver/xf86-dri-vivante_1.1.0.bb
b/recipes-graphics/xorg-driver/xf86-dri-vivante_1.1.0.bb
index 975041d..6e8f8db 100644
--- a/recipes-graphics/xorg-driver/xf86-dri-vivante_1.1.0.bb
+++ b/recipes-graphics/xorg-driver/xf86-dri-vivante_1.1.0.bb
@@ -30,6 +30,10 @@ do_install_append () {

       # FIXME: don't install libtool (*.la) file
       rm ${D}${libdir}/xorg/modules/extensions/*.la
+
+    # FIXME: The Xorg driver has a hardcoded library name
+    mv ${D}${libdir}/xorg/modules/extensions/libdri.so \
+       ${D}${libdir}/xorg/modules/extensions/libvivante_dri.so


I think you can use a symbolic link instead (as someone else has already
pointed before in the ML).

This makes it harder to have regular libdri.so packaged in same rootfs
in future. With the support for multiple CPUs in a single kernel (as
done in mainline) this should be started to be considered.

I got that. Agreed


Daiane

_______________________________________________
meta-freescale mailing list
[email protected]
https://lists.yoctoproject.org/listinfo/meta-freescale

Reply via email to