On 22 September 2016 at 09:40, Zhenhua Luo <zhenhua....@nxp.com> wrote:

> Currently qemu doesn't support ppce6500, accordingly gobject-introspection
> oesn't build for e6500 targets. Since the gobject-introspection-data
> feature
> is not needed for e6500, remove it from default build list.
>

gobject-introspection-data.bbclass:

GI_DATA_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES',
'gobject-introspection-data', \
                      bb.utils.contains('MACHINE_FEATURES',
'qemu-usermode', 'True', 'False', d), 'False', d)}"

Instead of manipulating DISTRO_FEATURES you can just set MACHINE_FEATURES
correctly.

Ross
-- 
_______________________________________________
meta-freescale mailing list
meta-freescale@yoctoproject.org
https://lists.yoctoproject.org/listinfo/meta-freescale

Reply via email to