Currently qemu doesn't support ppce6500, accordingly gobject-introspection
oesn't build for e6500 when introspection-data is enabled. Remove
qemu-usermode from MACHINE_FEATURES to disable introspection-data for
gobject-introspection build.

The e6500 support issue of qemu is tracked by:
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10304

Signed-off-by: Zhenhua Luo <zhenhua....@nxp.com>
---

Changes in v2:
- Set MACHINE_FEATURES instead of manipulating DISTRO_FEATURES.

 conf/machine/include/e6500-64b.inc | 2 ++
 conf/machine/include/e6500.inc     | 2 ++
 2 files changed, 4 insertions(+)

diff --git a/conf/machine/include/e6500-64b.inc 
b/conf/machine/include/e6500-64b.inc
index 33346d7..cc4fd10 100644
--- a/conf/machine/include/e6500-64b.inc
+++ b/conf/machine/include/e6500-64b.inc
@@ -6,6 +6,8 @@ require conf/machine/include/tune-ppce6500.inc
 MACHINEOVERRIDES =. "e6500-64b:"
 require conf/machine/include/qoriq-ppc.inc
 
+MACHINE_FEATURES_BACKFILL_CONSIDERED_append = " qemu-usermode"
+
 require conf/multilib.conf
 MULTILIBS ?= "multilib:lib32"
 DEFAULTTUNE_virtclass-multilib-lib32 ?= "ppce6500"
diff --git a/conf/machine/include/e6500.inc b/conf/machine/include/e6500.inc
index b838c8d..721a168 100644
--- a/conf/machine/include/e6500.inc
+++ b/conf/machine/include/e6500.inc
@@ -7,6 +7,8 @@ require conf/machine/include/qoriq-ppc.inc
 
 BUILD_64BIT_KERNEL = "1"
 
+MACHINE_FEATURES_BACKFILL_CONSIDERED_append = " qemu-usermode"
+
 require conf/multilib.conf
 MULTILIBS ?= "multilib:lib64"
 DEFAULTTUNE_virtclass-multilib-lib64 ?= "ppc64e6500"
-- 
2.7.4

-- 
_______________________________________________
meta-freescale mailing list
meta-freescale@yoctoproject.org
https://lists.yoctoproject.org/listinfo/meta-freescale

Reply via email to