Up ! nobody have an idea what's my problem ?

I'm very blocked with this issue and didn't find any help on this ?

This is normal that qmake QMAKE_SPEC give me linux-g++ ? How i can define them ?

regards

Mickaël.

Le 17/10/2016 à 10:07, idealsim a écrit :
Hi, since one week now i have a problem with my generated sdk. When i deploy sdk and configure qtCreator i have this error when i try do deploy an app :

/usr/bin/ld: skipping incompatible /opt/poky/secoA62/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libQt5Charts.so when searching for -lQt5Charts /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libQt5Charts.so when searching for -lQt5Charts
/usr/bin/ld: cannot find -lQt5Charts
/usr/bin/ld: skipping incompatible /opt/poky/secoA62/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libQt5Widgets.so when searching for -lQt5Widgets /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libQt5Widgets.so when searching for -lQt5Widgets
/usr/bin/ld: cannot find -lQt5Widgets
/usr/bin/ld: skipping incompatible /opt/poky/secoA62/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libQt5Gui.so when searching for -lQt5Gui /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libQt5Gui.so when searching for -lQt5Gui
/usr/bin/ld: cannot find -lQt5Gui
/usr/bin/ld: skipping incompatible /opt/poky/secoA62/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libQt5Core.so when searching for -lQt5Core /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libQt5Core.so when searching for -lQt5Core
/usr/bin/ld: cannot find -lQt5Core
/usr/bin/ld: skipping incompatible /opt/poky/secoA62/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libGLESv2.so when searching for -lGLESv2 /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libGLESv2.so when searching for -lGLESv2
/usr/bin/ld: cannot find -lGLESv2
/usr/bin/ld: skipping incompatible /opt/poky/secoA62/sysroots/cortexa9hf-neon-poky-linux-gnueabi/usr/lib/libpthread.so when searching for -lpthread /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libpthread.so when searching for -lpthread /usr/bin/ld: skipping incompatible /home/mls/yocto-seco/secoA62q/tmp/sysroots/secosbca62/usr/lib/libpthread.a when searching for -lpthread
collect2: error: ld returned 1 exit status
make: *** [barchart] Error 1
09:57:17: Le processus "/usr/bin/make" s'est terminé avec le code 2.

For information we are on krogoth branch for oe/poky ... and master in meta-qt5 (for qt5.7). We have no warning or error during the build.

I also see that qmake -query (the qmake give by the sdk in /x86_64-pokysdk-linux/usr/bin/qt5/bin) give this :

QT_EXTERNAL_HOST_BINS:
QMAKE_SPEC:linux-g++
QMAKE_XSPEC:linux-g++
QMAKE_VERSION:3.0
QT_VERSION:5.7.0

and before for a working sdk, i have this for qmake -query :

QT_EXTERNAL_HOST_BINS:
QMAKE_SPEC:/home/mls/yoctoUdoo/neoBuild/tmp/sysroots/x86_64-linux/usr/lib/qt5/mkspecs/linux-oe-g++
QMAKE_XSPEC:linux-oe-g++
QMAKE_VERSION:3.0
QT_VERSION:5.6.1

I think a problem with QMAKE_SPEC, but i don't know how to resolve this !

If someone can help please !

Mickaël



--
_______________________________________________
meta-freescale mailing list
meta-freescale@yoctoproject.org
https://lists.yoctoproject.org/listinfo/meta-freescale

Reply via email to