Dear All, I'm struggling with the imx-gstreamer on a SABRE iMX6 quad core. I 
have prepare an image with Ubuntu 16 and compiled gstreamer iMX. I would like 
to use the imxg2dcompositor to gather 4 h264 streams. 
The pipeline I have prepared, following some docs on the Network, is the 
gst-launch-1.0 \
imxg2dcompositor name=c background-color=0xFF \
sink_0::xpos=0 sink_0::ypos=0 sink_0::width=400 sink_0::height=300 \
sink_1::xpos=400 sink_1::ypos=0 sink_1::width=400 sink_1::height=300  \
queue2 ! video/x-raw, width=800, height=600 ! imxipuvideosink \
rtspsrc location=rtsp://<user>:<pwd>@ ! rtph264depay ! 
h264parse ! imxvpudec ! queue2 ! c.sink_0 \
rtspsrc location=rtsp://<user>:<pwd>@ ! rtph264depay ! 
h264parse ! imxvpudec ! queue2 ! c.sink_1
I have got to face with the following  problem: the video is black, none of the 
streams is visible.  

Please note that if i show the 4 streams not grouped, but arranged with x,y 
coordinates in a sink like img2dvideosink, it works perfectly.

Moreover, if I convert the pipe on my Ubuntu workstation (with the "normal" 
compositor, and using avdec_h264 + videoconvert ) it works like a charm.

Finally, if I use the same stream (2 times the H264 from a same camera), it 
I have tried several tests to solve the problem, went to any corner of google, 
but I haven't found out any interesting answer.
Btw, I have also tried the imxipucompositor: same problem.
Where I wrong?
Thank you for any advise. I’m going crazy.

PS: I have tried to use on the imx pipeline above the software “compositor”: it 
works and I can see the 4 streams, but is not acceptable because is too slow. 
So, I come back to my question: why it doesn’t work in this way?
meta-freescale mailing list

Reply via email to