Hello,

I can not produced this issue.

I  can build pass base the below commit.
Build Configuration:
BB_VERSION        = "1.35.0"
BUILD_SYS         = "x86_64-linux"
NATIVELSBSTRING   = "ubuntu-16.04"
TARGET_SYS        = "aarch64-poky-linux"
MACHINE           = "ls1043ardb"
DISTRO            = "poky"
DISTRO_VERSION    = "2.3"
TUNE_FEATURES     = "aarch64"
TARGET_FPU        = ""
meta
meta-poky         = "master:8e15e9b6e478f6368034519b2a8fd3c7ea71d23b"
meta-freescale    = "master:0b1bb9b69fe73e9933c8e16a11a7cd1095ae8072"
meta-yocto-bsp    = "master:8e15e9b6e478f6368034519b2a8fd3c7ea71d23b"

cryptodev-linux has been updated to 1.9 version in poky now.

you can update  your layer to new commit.

Note : you must apply the below patch to meta-freescale
https://patchwork.openembedded.org/patch/142374/


Thanks
Chunrong


From: meta-freescale-boun...@yoctoproject.org 
[mailto:meta-freescale-boun...@yoctoproject.org] On Behalf Of vr roriz
Sent: Tuesday, July 25, 2017 4:26 PM
To: meta-freescale@yoctoproject.org
Subject: [meta-freescale] [Error cryptodev-linux] Conflict with meta layer

Dear all,
I am trying to compile a core-image-minimal, using the 4.1-2.0 Kernel version.
I keep getting the ERROR: Multiple .bb files are due to be built which each 
provide cryptodev-linux.  I already tried to wipe out the output / sstatechache 
dir, and call clean -c <recipe>, and also cleansstate.

The conflict is between:
  
/home/vroriz/poky/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.8.bb<http://cryptodev-qoriq-linux_1.8.bb>
  
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb<http://cryptodev-linux_1.8.bb>

The output for tracing is:
A list of tasks depending on these providers is shown and may help explain 
where the dependency comes from.
/home/vroriz/poky/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.8.bb<http://cryptodev-qoriq-linux_1.8.bb>
 has unique dependees:
  
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb:do_build
  
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb:do_package_qa
  
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb:do_package_write_rpm
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb<http://cryptodev-linux_1.8.bb>
 has unique dependees:
  
/home/vroriz/poky/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb:do_package
  
/home/vroriz/poky/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb:do_configure
  /home/vroriz/poky/meta/recipes-core/images/core-image-minimal.bb:do_image
It could be that one recipe provides something the other doesn't and should. 
The following provider and runtime provider differences may be helpful.
/home/vroriz/poky/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.8.bb<http://cryptodev-qoriq-linux_1.8.bb>
 has unique provides:
  cryptodev-qoriq-linux
/home/vroriz/poky/meta-freescale/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.8.bb<http://cryptodev-qoriq-linux_1.8.bb>
 has unique rprovides:
  cryptodev-qoriq-linux-doc
  cryptodev-qoriq-linux
  cryptodev-qoriq-linux-staticdev
  cryptodev-qoriq-linux-locale
  cryptodev-qoriq-linux-dbg
  cryptodev-qoriq-linux-dev
  ^cryptodev-qoriq-linux-locale-.*
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb<http://cryptodev-linux_1.8.bb>
 has unique provides:
/home/vroriz/poky/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb<http://cryptodev-linux_1.8.bb>
 has unique rprovides:
  ^cryptodev-linux-locale-.*
BR,
Vitor Roriz


-- 
_______________________________________________
meta-freescale mailing list
meta-freescale@yoctoproject.org
https://lists.yoctoproject.org/listinfo/meta-freescale

Reply via email to