I’ve run into a bit of a corner trying to get a particular chip working. We are 
using pyro layer with Qt 5.9. The driver I’m looking for is in kernel 4.4 and 
beyond. I made a short attempt to backport it to 3.14 but there are some major 
differences with 3.14, mostly in the kthread interface that doesn’t seem to be 
present. Same with 4.1.


drivers/tty/serial/sc16is7xx.c:711:2: error: implicit declaration of function 
‘kthread_queue_work’ [-Werror=implicit-function-declaration]

  kthread_queue_work(&s->kworker, &s->irq_work);

I also attempted to update to 4.9 and what I’m getting stuck on is there is no 
Qt support for the latest kernel + vivante driver. If I just pull in the 
6.2.2.p0 driver alone Qt fails to run with a stack trace error. If I pull in 
everything Qt fails to compile, even all the way to 5.11 so I’m not sure which 
branch I should use for the upcoming sumo release.

I’m not sure which is the easiest path forward at this point.  Currently I’m 
looking at attempting to backport the 4.9 driver to 4.1 since those are very 
similar.

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

-- 
_______________________________________________
meta-freescale mailing list
meta-freescale@yoctoproject.org
https://lists.yoctoproject.org/listinfo/meta-freescale

Reply via email to