On Sun, Oct 16, 2016 at 12:46:19PM +0200, Gary Thomas wrote:
> On 2016-10-11 12:47, Denys Dmytriyenko wrote:
> >Yeah, I'm also getting this in master. Works fine in krogoth. Haven't yet 
> >looked close at it though...
> 
> There seem to be two things wrong here.
> 
> *) Yocto has moved most recipes to use a split source/build tree,
>    thus ${S} != ${B}

Well, that actually happened quite a long time ago for most of recipes. U-boot 
was in the unconverted minority for a while, until couple months ago:

http://cgit.openembedded.org/openembedded-core/commit/?id=36f110594506fbee5dc18de3a04981f019f2024d


As of UBOOT_LOCALVERSION - not sure if generating it fails or rather 
consumption of it fails inside U-boot Makefiles...

-- 
Denys


> *) There is some issue with generating the UBOOT_LOCALVERSION that
>    causes problems.
> 
> This patch [sort of] addresses both.  At least it lets me build a
> working U-Boot for the BeagleBone from master.  I know it's not
> perfect, but I couldn't figure out the why the UBOOT_LOCALVERSION
> stuff wasn't working.
> 
> -- 
> ------------------------------------------------------------
> Gary Thomas                 |  Consulting for the
> MLB Associates              |    Embedded world
> ------------------------------------------------------------

> diff --git a/recipes-bsp/u-boot/u-boot-ti.inc 
> b/recipes-bsp/u-boot/u-boot-ti.inc
> index b0054c9..a854243 100644
> --- a/recipes-bsp/u-boot/u-boot-ti.inc
> +++ b/recipes-bsp/u-boot/u-boot-ti.inc
> @@ -8,7 +8,7 @@ def get_git_revision(p):
>      except OSError:
>          return None
>  
> -UBOOT_LOCALVERSION = "-g${@get_git_revision('${S}').__str__()[:10]}"
> +#UBOOT_LOCALVERSION = "-g${@get_git_revision('${S}').__str__()[:10]}"
>  
>  UBOOT_SUFFIX ?= "img"
>  
> @@ -36,7 +36,7 @@ SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
>  do_install_append () {
>      if [ "x${SPL_UART_BINARY}" != "x" ]
>      then
> -        install ${S}/spl/${SPL_UART_BINARY} ${D}/boot/${SPL_UART_IMAGE}
> +        install ${B}/spl/${SPL_UART_BINARY} ${D}/boot/${SPL_UART_IMAGE}
>          ln -sf ${SPL_UART_IMAGE} ${D}/boot/${SPL_UART_BINARY}
>      fi
>  }
> @@ -45,7 +45,7 @@ do_deploy_append () {
>      cd ${DEPLOYDIR}
>      if [ "x${SPL_UART_BINARY}" != "x" ]
>      then
> -        install ${S}/spl/${SPL_UART_BINARY} ${DEPLOYDIR}/${SPL_UART_IMAGE}
> +        install ${B}/spl/${SPL_UART_BINARY} ${DEPLOYDIR}/${SPL_UART_IMAGE}
>          rm -f ${DEPLOYDIR}/${SPL_UART_BINARY} 
> ${DEPLOYDIR}/${SPL_UART_SYMLINK}
>          ln -sf ${SPL_UART_IMAGE} ${DEPLOYDIR}/${SPL_UART_BINARY}
>          ln -sf ${SPL_UART_IMAGE} ${DEPLOYDIR}/${SPL_UART_SYMLINK}

> -- 
> _______________________________________________
> meta-ti mailing list
> meta-ti@yoctoproject.org
> https://lists.yoctoproject.org/listinfo/meta-ti

-- 
_______________________________________________
meta-ti mailing list
meta-ti@yoctoproject.org
https://lists.yoctoproject.org/listinfo/meta-ti

Reply via email to