Hi Richard, Nope, not boring at all. In fact, most useful. I, too have read your guide a bunch of moons ago, and have implemented many of the naming conventions you describe. At first, I believed, as Andu said, "it's up to the individual." But, I started using your naming conventions primarily because I offer free scripts and controls at my website and wanted them readable by others. As it turns out, they're also more readable by myself!
I mostly follow your variable naming conventions. Sometimes adding "grp" on the front of a group object gets quite long...especially if the group object is a control of my making, then I usually just add the word "alt" (for Altuit, my company:-). So, a control of mine might be altThumbBrowser rather that grpaltThumbBrowser. Also, grp, fld, img, etc, names are alway preceeded by the type of control anyway. I digress (and now poor Andu is bored to tears! :-). I'm with Sarah on the array naming conventions. Easier to read. Anyway, thanks for the post, and a bigger thanks for the article and the thoughts in it! -Chipp _______________________________________________ metacard mailing list [EMAIL PROTECTED] http://lists.runrev.com/mailman/listinfo/metacard
