On Wed, 16 Apr 2008, Casey Mills wrote:

http://www.i-hacked.com/index.php...

That is kinda cool. I do this with a MT router (of course)...the config is MUCH less convoluted, however....

1. Get a MT router with 2 wireless interfaces

2. Config is as follows (for 2.9.x):
Assuming wlan1 is to be the "predator" interface and wlan2 is your connection:

/interface wireless connect-list
add interface=wlan1 connect=yes

/interface wireless security-profiles

add authentication-types=wpa2-psk group-ciphers=tkip \
    mode=dynamic-keys name="secureprofile" \
    wpa2-pre-shared-key="wpakeyforme"

/interface wireless
set wlan1 mode=station
set wlan2 mode=ap-bridge ssid=SSIDFORMETOUSE \
    default-authenticate=yes default-forward=no
    profile=secureprofile

3. Add dhcp-client to wlan1:
/ip dhcp-client
add add-default-route=yes disabled=no \
  interface=wlan1 use-peer-dns=yes

4. Set up IP addresses/dhcp on the wlan2 interface

5. Create a NAT rule that masquerades all traffic out the wlan1 interface:
/ip firewall nat
add out-interface=wlan1 action=masquerade chain=srcnat

That's about it...unless I forgot something.  ;-)

--
********************************************************************
*Butch Evans                    *Professional Network Consultation *
*Network Engineering            *MikroTik RouterOS                 *
*573-276-2879                   *ImageStream                       *
*http://www.butchevans.com/     *StarOS and MORE                   *
*Mikrotik Certified Consultant  *Wired or Wireless Networks        *
********************************************************************

Reply via email to