I can confirm that the patch works for me with gcc-6.1.0 to build qt5.

Thanks! Mario


On 17.09.2016 23:56, David Wohlferd wrote:
> It took me a bit to figure out the difference between my test code (which
> requires the patch) and yours (which can't have it). It was subtle.
> 
> Try this patch (attached).
> 
> dw
> 
> On 9/16/2016 1:39 AM, Mateusz wrote:
>> Hello,
>> Since this commit I'm not able to compile Qt5 with GCC 6.1.0 and 6.2.0
>> errors:
>>
>> In file included from
>> D:/msys64/mingw64/x86_64-w64-mingw32/include/mfidl.h:73:0,
>>                   from example.cc:1:
>> D:/msys64/mingw64/x86_64-w64-mingw32/include/mftransform.h:709:47: error:
>> 'selectany' attribute applies only to initialized variables with external
>> linkage
>>   EXTERN_C const DECLSPEC_SELECTANY PROPERTYKEY MFPKEY_CLSID =
>> {{0xc57a84c0,0x1a80,0x40a3,{0x97,0xb5,0x92,0x72,0xa4,0x3,0xc8,0xae}}, 0x01};
>>                                                 ^~~~~~~~~~~~



------------------------------------------------------------------------------
_______________________________________________
Mingw-w64-public mailing list
Mingw-w64-public@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/mingw-w64-public

Reply via email to