On 01/12/16 14:29, Alan Griffiths wrote:
> On 01/12/16 13:18, Kevin DuBois wrote:
>> MirRenderSurface I hope will get a shorter name that closer to a
>> one word noun. Although the ideal of making it MirSurface after
>> the existing MirSurface becomes MirWindow is quite ambitious.
>> Agree. I think it needs to be done before 1.0, and would be nice to
>> do before making the header public.
> Are we really intending to rework all the code "out there" that refers
> to MirSurface?!
I think we should instead to something like: Add MrSurface and MrWindow.
And for backwards compatibility:
typedef MirSurface MrWindow;
Mir-devel mailing list
Modify settings or unsubscribe at: