Completely forgot about MirBufferStream too. When it was first introduced some years ago I suggested more correct (and elegant) names were:
   MirSurface -> MirWindow
   MirBufferStream -> MirSurface

Now we've got a third object 'MirRenderSurface' coming I'm not even sure what the ideal naming scheme is.

Can we avoid having three objects and somehow keep it at two? Isn't MirBufferStream going to be just a specific case/mode of a MirRenderSurface?

On 02/12/16 09:34, Daniel van Vugt wrote:
Indeed that was my position a couple of months ago. But I was swayed by
the team's bullishness about ABI/API breaks before "1.0". I mentioned
that was still only an ideal though...

More realistically I think we'll probably end up keeping MirSurface as
is, because that nomenclature has permeated too far beyond a single
codebase already. That just makes finding a better name for
MirRenderSurface a bit more difficult.

On 01/12/16 22:29, Alan Griffiths wrote:
On 01/12/16 13:18, Kevin DuBois wrote:

    MirRenderSurface I hope will get a shorter name that closer to a
    one word noun. Although the ideal of making it MirSurface after
    the existing MirSurface becomes MirWindow is quite ambitious.

Agree. I think it needs to be done before 1.0, and would be nice to do
before making the header public.

Are we really intending to rework all the code "out there" that refers
to MirSurface?!

I agree the name is wrong, but I think the time to change it has


[*] If only version control systems /1/ understood refactorings, and /2/
talked to each other.

Mir-devel mailing list
Modify settings or unsubscribe at:

Reply via email to