On Mon, Feb 19, 2018 at 11:21:09AM -0800, Mike Larkin wrote:
> On Mon, Feb 19, 2018 at 11:12:52AM -0800, Mike Larkin wrote:
> > On Mon, Feb 19, 2018 at 02:40:47PM +0100, Robert Paschedag wrote:
> > > Hi misc,
> > > 
> > > I am running STABLE and just started testing running debian within vmd and
> > > this works quite well right now.
> > > 
> > > Now I noticed, that vmctl status shows the vm as STOPPED, although it is
> > > running.
> > > 
> > > I can connect to the console without problems. Is this status showing some
> > > "other" status?
> > > 
> > > Thanks.
> > > Robert
> > > 
> > 
> > An OS can spent a large amount of time "doing nothing" - eg, in it's idle 
> > loop.
> > 
> 
> What horrible English. This was written before coffee. "spend" and "its" are, 
> of
> course, what I meant to type there.

gotta love Mondays when your correction itself is wrong. time for coffee.


> 
> > What you are seeing is that your guest OS has executed a HLT instruction 
> > (likely
> > in that idle loop) and thus, vmd is not running at that precise instant in 
> > time
> > when you ran the command, because there is nothing to do.
> > 
> > I bet if you ran something that consumed guest CPU, and ran the same 
> > command,
> > you'd see something else.
> > 
> > -ml
> > 
> > > pasche@tux2:~$ vmctl status
> > >    ID   PID VCPUS  MAXMEM  CURMEM     TTY        OWNER NAME
> > >     1 10854     1    2.0G    217M   ttyp2       pasche debian
> > > pasche@tux2:~$ vmctl status 1
> > >    ID   PID VCPUS  MAXMEM  CURMEM     TTY        OWNER NAME
> > >     1 10854     1    2.0G    217M   ttyp2       pasche debian
> > >  VCPU:  0 STATE: STOPPED
> > > pasche@tux2:~$ ps aux | grep vmd
> > > _vmd     41407  0.0  0.0  1188  1756 ??  Ssp    2:16PM    0:00.01 vmd: vmm
> > > (vmd)
> > > root     79080  0.0  0.0  1112  1640 ??  Is     2:16PM    0:00.01 vmd: 
> > > priv
> > > (vmd)
> > > _vmd     51293  0.0  0.0  1184  1732 ??  Ssp    2:16PM    0:00.01 vmd:
> > > control (vmd)
> > > root     82177  0.0  0.0  1364  1672 ??  Ssp    2:16PM    0:00.01
> > > /usr/sbin/vmd
> > > _vmd     10854  0.0  0.4 2099748 64808 ??  Ip     2:16PM    0:20.73 vmd:
> > > debian (vmd)
> > > pasche   24262  0.0  0.0   132   328 p1  R+/1   2:39PM    0:00.00 grep vmd
> > > pasche@tux2:~$ vmctl console 1
> > > Connected to /dev/ttyp2 (speed 115200)
> > > 
> > > Debian GNU/Linux 9 debian-vm ttyS0
> > > 
> > > debian-vm login:
> > > [EOT]
> > > pasche@tux2:~$
> > > 
> > > 
> > > OpenBSD 6.2 (GENERIC.MP) #5: Fri Feb  2 23:02:19 CET 2018
> > > 
> > > r...@syspatch-62-amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> > > real mem = 16708087808 (15934MB)
> > > avail mem = 16194699264 (15444MB)
> > > mpath0 at root
> > > scsibus0 at mpath0: 256 targets
> > > mainbus0 at root
> > > bios0 at mainbus0: SMBIOS rev. 2.7 @ 0xdae9d000 (68 entries)
> > > bios0: vendor LENOVO version "HEET34WW (1.15 )" date 07/02/2013
> > > bios0: LENOVO 68852HG
> > > acpi0 at bios0: rev 2
> > > acpi0: sleep states S0 S3 S4 S5
> > > acpi0: tables DSDT FACP SSDT SSDT ASF! HPET APIC MCFG FPDT SSDT SSDT UEFI
> > > UEFI POAT UEFI DBG2
> > > acpi0: wakeup devices P0P1(S4) EHC1(S3) EHC2(S3) XHC_(S3) HDEF(S3) 
> > > PXSX(S4)
> > > RP01(S4) PXSX(S4) RP02(S4) PXSX(S4) RP03(S4) PXSX(S4) RP04(S4) PXSX(S4)
> > > RP05(S4) PXSX(S4) [...]
> > > acpitimer0 at acpi0: 3579545 Hz, 24 bits
> > > acpihpet0 at acpi0: 14318179 Hz
> > > acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> > > cpu0 at mainbus0: apid 0 (boot processor)
> > > cpu0: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 2594.51 MHz
> > > cpu0: 
> > > FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
> > > cpu0: 256KB 64b/line 8-way L2 cache
> > > cpu0: TSC frequency 2594510480 Hz
> > > cpu0: smt 0, core 0, package 0
> > > mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
> > > cpu0: apic clock running at 99MHz
> > > cpu0: mwait min=64, max=64, C-substates=0.2.1.1.2, IBE
> > > cpu1 at mainbus0: apid 1 (application processor)
> > > cpu1: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 2594.10 MHz
> > > cpu1: 
> > > FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
> > > cpu1: 256KB 64b/line 8-way L2 cache
> > > cpu1: smt 1, core 0, package 0
> > > cpu2 at mainbus0: apid 2 (application processor)
> > > cpu2: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 2594.10 MHz
> > > cpu2: 
> > > FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
> > > cpu2: 256KB 64b/line 8-way L2 cache
> > > cpu2: smt 0, core 1, package 0
> > > cpu3 at mainbus0: apid 3 (application processor)
> > > cpu3: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 2594.10 MHz
> > > cpu3: 
> > > FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,RDTSCP,LONG,LAHF,PERF,ITSC,FSGSBASE,SMEP,ERMS,SENSOR,ARAT
> > > cpu3: 256KB 64b/line 8-way L2 cache
> > > cpu3: smt 1, core 1, package 0
> > > ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
> > > acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
> > > acpiprt0 at acpi0: bus 0 (PCI0)
> > > acpiprt1 at acpi0: bus -1 (P0P1)
> > > acpiprt2 at acpi0: bus 3 (RP01)
> > > acpiprt3 at acpi0: bus 4 (RP02)
> > > acpiprt4 at acpi0: bus -1 (RP03)
> > > acpiprt5 at acpi0: bus 5 (RP04)
> > > acpiprt6 at acpi0: bus -1 (RP05)
> > > acpiprt7 at acpi0: bus -1 (RP06)
> > > acpiprt8 at acpi0: bus -1 (RP07)
> > > acpiprt9 at acpi0: bus -1 (RP08)
> > > acpiprt10 at acpi0: bus -1 (PEG0)
> > > acpiprt11 at acpi0: bus -1 (PEG1)
> > > acpiprt12 at acpi0: bus -1 (PEG2)
> > > acpiprt13 at acpi0: bus -1 (PEG3)
> > > acpiec0 at acpi0
> > > acpicpu0 at acpi0: C3(200@87 mwait.1@0x30), C2(500@59 mwait.1@0x10),
> > > C1(1000@1 mwait.1), PSS
> > > acpicpu1 at acpi0: C3(200@87 mwait.1@0x30), C2(500@59 mwait.1@0x10),
> > > C1(1000@1 mwait.1), PSS
> > > acpicpu2 at acpi0: C3(200@87 mwait.1@0x30), C2(500@59 mwait.1@0x10),
> > > C1(1000@1 mwait.1), PSS
> > > acpicpu3 at acpi0: C3(200@87 mwait.1@0x30), C2(500@59 mwait.1@0x10),
> > > C1(1000@1 mwait.1), PSS
> > > acpitz0 at acpi0: critical temperature is 100 degC
> > > "INT3F0D" at acpi0 not configured
> > > acpithinkpad0 at acpi0
> > > "PNP0C14" at acpi0 not configured
> > > acpibat0 at acpi0: BAT0 model "45N1045" serial    99 type LION oem "SMP"
> > > acpiac0 at acpi0: AC unit offline
> > > "PTL0001" at acpi0 not configured
> > > "LEN2002" at acpi0 not configured
> > > acpibtn0 at acpi0: PWRB
> > > acpibtn1 at acpi0: LID0
> > > "INT340E" at acpi0 not configured
> > > acpivideo0 at acpi0: VID_
> > > acpivout at acpivideo0 not configured
> > > cpu0: Enhanced SpeedStep 2594 MHz: speeds: 2601, 2600, 2500, 2400, 2300,
> > > 2200, 2100, 2000, 1900, 1800, 1700, 1600, 1500, 1400, 1300, 1200 MHz
> > > pci0 at mainbus0 bus 0
> > > pchb0 at pci0 dev 0 function 0 "Intel Core 3G Host" rev 0x09
> > > inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 4000" rev 0x09
> > > drm0 at inteldrm0
> > > inteldrm0: msi
> > > inteldrm0: 1366x768, 32bpp
> > > wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
> > > wsdisplay0: screen 1-5 added (std, vt100 emulation)
> > > xhci0 at pci0 dev 20 function 0 "Intel 7 Series xHCI" rev 0x04: msi
> > > usb0 at xhci0: USB revision 3.0
> > > uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev
> > > 3.00/1.00 addr 1
> > > "Intel 7 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
> > > ehci0 at pci0 dev 26 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 
> > > 16
> > > usb1 at ehci0: USB revision 2.0
> > > uhub1 at usb1 configuration 1 interface 0 "Intel EHCI root hub" rev
> > > 2.00/1.00 addr 1
> > > azalia0 at pci0 dev 27 function 0 "Intel 7 Series HD Audio" rev 0x04: msi
> > > azalia0: codecs: Conexant CX20590, Intel/0x2806, using Conexant CX20590
> > > audio0 at azalia0
> > > ppb0 at pci0 dev 28 function 0 "Intel 7 Series PCIE" rev 0xc4: msi
> > > pci1 at ppb0 bus 3
> > > rtsx0 at pci1 dev 0 function 0 "Realtek RTS5229 Card Reader" rev 0x01: msi
> > > sdmmc0 at rtsx0: 4-bit
> > > ppb1 at pci0 dev 28 function 1 "Intel 7 Series PCIE" rev 0xc4: msi
> > > pci2 at ppb1 bus 4
> > > iwn0 at pci2 dev 0 function 0 "Intel Centrino Wireless-N 2230" rev 0xc4:
> > > msi, MIMO 2T2R, BGN, address 68:17:29:ec:ca:7f
> > > ppb2 at pci0 dev 28 function 3 "Intel 7 Series PCIE" rev 0xc4: msi
> > > pci3 at ppb2 bus 5
> > > re0 at pci3 dev 0 function 0 "Realtek 8168" rev 0x07: RTL8168E/8111E-VL
> > > (0x2c80), msi, address 28:d2:44:26:fa:e9
> > > rgephy0 at re0 phy 7: RTL8169S/8110S/8211 PHY, rev. 5
> > > ehci1 at pci0 dev 29 function 0 "Intel 7 Series USB" rev 0x04: apic 2 int 
> > > 23
> > > usb2 at ehci1: USB revision 2.0
> > > uhub2 at usb2 configuration 1 interface 0 "Intel EHCI root hub" rev
> > > 2.00/1.00 addr 1
> > > pcib0 at pci0 dev 31 function 0 "Intel HM77 LPC" rev 0x04
> > > ahci0 at pci0 dev 31 function 2 "Intel 7 Series AHCI" rev 0x04: msi, AHCI
> > > 1.3
> > > ahci0: port 0: 6.0Gb/s
> > > ahci0: port 2: 1.5Gb/s
> > > scsibus1 at ahci0: 32 targets
> > > sd0 at scsibus1 targ 0 lun 0: <ATA, Crucial_CT525MX3, M0C> SCSI3 0/direct
> > > fixed naa.500a075116e63f65
> > > sd0: 500786MB, 512 bytes/sector, 1025610768 sectors, thin
> > > cd0 at scsibus1 targ 2 lun 0: <HL-DT-ST, DVDRAM GU70N, LE20> ATAPI 5/cdrom
> > > removable
> > > ichiic0 at pci0 dev 31 function 3 "Intel 7 Series SMBus" rev 0x04: apic 2
> > > int 18
> > > iic0 at ichiic0
> > > spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
> > > spdmem1 at iic0 addr 0x52: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
> > > isa0 at pcib0
> > > isadma0 at isa0
> > > pckbc0 at isa0 port 0x60/5 irq 1 irq 12
> > > pckbd0 at pckbc0 (kbd slot)
> > > wskbd0 at pckbd0: console keyboard, using wsdisplay0
> > > pms0 at pckbc0 (aux slot)
> > > wsmouse0 at pms0 mux 0
> > > wsmouse1 at pms0 mux 0
> > > pms0: Synaptics clickpad, firmware 8.1, 0x1e2b1 0x940300
> > > pcppi0 at isa0 port 0x61
> > > spkr0 at pcppi0
> > > vmm0 at mainbus0: VMX/EPT
> > > error: [drm:pid0:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch 
> > > fifo
> > > underrun on pch transcoder A
> > > error: [drm:pid0:intel_pch_fifo_underrun_irq_handler] *ERROR* PCH 
> > > transcoder
> > > A FIFO underrun
> > > uhub3 at uhub1 port 1 configuration 1 interface 0 "Intel Rate Matching 
> > > Hub"
> > > rev 2.00/0.00 addr 2
> > > ugen0 at uhub3 port 3 "Intel product 0x07da" rev 2.00/78.69 addr 3
> > > ugen1 at uhub3 port 4 "Validity Sensors VFS5011 Fingerprint Reader" rev
> > > 1.10/0.78 addr 4
> > > uvideo0 at uhub3 port 6 configuration 1 interface 0 "Vimicro corp.
> > > Integrated Camera" rev 2.00/39.89 addr 5
> > > video0 at uvideo0
> > > uhub4 at uhub2 port 1 configuration 1 interface 0 "Intel Rate Matching 
> > > Hub"
> > > rev 2.00/0.00 addr 2
> > > vscsi0 at root
> > > scsibus2 at vscsi0: 256 targets
> > > softraid0 at root
> > > scsibus3 at softraid0: 256 targets
> > > root on sd0a (142ebbf3d95f9810.a) swap on sd0b dump on sd0b
> > > 
> > 
> 

Reply via email to