On 04/11/18 10:50, Stuart Henderson wrote:
On 2018-04-10, csszep <css...@gmail.com> wrote:

I installed the latest 04.10 snapshot, the install procedure went fine, but
after reboot the VM stucks at endless boot loop .

It prints only the "booting hda0:/bsd" line.. before reboot

The 04.03 snapshot works fine.

There is a similar experience for someone with Virtualbox 5.2.8?

There's a recent bootloader problem, possibly following the update
to clang 6, that affects some machines. I suspect this might be
involved here.
Ah, that might (?) explain what was happening to me with a Lenovo Thinkpad X1 Carbon?

Not a VM.

Stuck in an endless boot loop, with a flash of a "heap full" message before the next reboot.

Tried the same snapshot on an older Thinkpad and no issues.

Looked like it was a possible SSD problem (from what I could find in the archives), so I tried the 6.3 installer and that was fine.

Repeated the snapshot install and got back into the endless rebooting.

To confirm if this is the problem, can you install the older
snapshot as normal, then update kernel and file sets to the newer
one? (follow the "Upgrade without the install kernel" steps on
http://www.openbsd.org/faq/upgrade63.html, except skip the part
about running installboot do install a new bootloader).

Can you report back either way please (preferably to bugs@, with
dmesg and anything special about the VM config).. If it is the
same thing it would be useful for developers to have a way to
reproduce the problem that doesn't involve specific hardware..

Reply via email to