On Mon, Apr 16, 2018 at 04:15:42PM +0200, Daniel Santos wrote:
> I looking for some experience sharing from those who also run OpenBSD inside
> KVM on Linux.
> 
> I was running 5.2 and now 6.2 inside KVM on a Linux wheezy host with 3.2
> kernel.
> 
> This system was used as an all in one Zabbix monitoring server, which
> included the full stack required to run a central monitoring server:
> 
> -Lighttpd
> -Zabbix Server
> -Zabbix Agent
> -Mysql Server
> -SNMP utils
> 
> First it was using Zabbix 2.x then I have upgraded it to the 3.x series. The
> zabbix server was regularily crashing or stopped logging to the DB and
> needed to be restarted.
> If not that then the db and page load was terribly slow even on LAN and I
> only had <15 clients on this server. I started moving the components off one
> by one, at the end only the zabbix server engine left on the vm even that
> sometimes just stuck and stopped sending data to a standalone other linux
> mysql vm. Then I gave up, I recreated the whole environment with the same
> Zabbix version on an all in one Debian 9 vm and since then it runs
> flawlessly. Another issue was that I kept getting dropped packet entries in
> my pflog on the enabled ports (seems like broken connections).
> 

Zabbix needs a fast DB which I would not run virtualised. Also the crashes
you have seen may have been fixed in the meantime (between 6.2 and 6.3
there was an libc asr fix that made zabbix reliable for me).

I run a few KVM OpenBSD machines (mainly network / load balancers) they
work reasonably well.

-- 
:wq Claudio

Reply via email to