On February 1, 2020 12:27:40 AM GMT+02:00, "Luke A. Call" 
<luke...@onemodel.org> wrote:
>Cancel the cancellation.
>I am still seeing this problem, even after logging out/in and ulimit -u
>shows 712.   Running "ps -U myusername|less" yields about 180 lines and
>the system becomes unable to start even another xterm, or in tmux on a
>console, unable to start another shell window (in both cases: "Resource
>temporarily unavailable").
>
>On 01-31 13:20, Luke A. Call wrote:
>> Hi misc.  
>> 
>> Am I running into a limit that will require recompiling the kernel
>> (or changing my work style I suppose)?  Which man pages should I read
>> next, or should I be thinking about this differently?
>> 
>> I am getting "Resource temporarily unavailable" in
>> /var/log/authlog when I try to open too many "ssh [-X]
>user@localhost"
>> connections, or even "fork: retry: Resource temporarily unavailable"
>when
>> running "$ cat > /tmp/somefile".  
>> 
>> In "man 3 __tfork" I see:
>> [EAGAIN]        Resource temporarily unavailable.  The system-imposed
>>              limit on the total number of threads under execution
>>              would be exceeded.  This limit is configuration-
>>              dependent.
>> 
>> [EAGAIN]        Resource temporarily unavailable.  The system-imposed
>>              limit MAXUPRC on the total number of threads under
>>              execution by a single user would be exceeded.  MAXUPRC
>>              is currently defined in <sys/param.h> as CHILD_MAX,
>>              which is currently defined as 80 in <sys/syslimits.h>.
>> 
>> (If multiple users could simultaneously run X, I might not ssh as
>much;
>> suggestions welcome there also, if you are in the mood.)
>> 
>> 
>> More details, not sure if needed:
>> 
>> When I open a large # of xterms which make ssh -X connections on
>> my laptop with obsd 6.5 (planning to upgrade, haven't quite yet),
>they at 
>> first pause saying
>>   -bash: fork: retry: Resource temporarily unavailable
>> ...then start failing with 
>>   shell request failed on channel 0
>> ...and in /var/log/authlog I see:
>>   sshd[52954]: error: do_exec_pty: fork: Resource temporarily
>unavailable
>> 
>> Also, until recently I would get error messages in ~/.xsession-errors
>like:
>>   xterm: Error 32, errno 6: Device not configured   Reason: 
>>   get_pty: not enough ptys
>> ...but, after creating more ptys by running (as root)
>>   cd /dev; sh MAKEDEV pty1  #then, um, with pty2, pty3, 4, and 5
>> 
>> ...I don't seem to get the "not enough ptys" anymore, and can open
>> all the xters I like, but I get the
>> above "xterm: Error 32, errno 6: Device not configured   Reason:
>> get_pty: not enough ptys" from authlog, and the "shell request failed
>> on channel 0" from the ssh client, all even when I do this not under
>X.  
>> 
>> It's like I can't get beyond about 20-23 "ssh user@localhost"
>connections
>> (depending on how they are counted).
>> 
>> I have expanded limits in /etc/login.conf and kern.maxfiles=3500 now,
>in
>> sysctl.conf, but that is just poking in the dark.
>> 
>> What am I missing? Thanks!
>> -Luke
>> 
>> dmesg:
>> ached
>> uhidev4 detached
>> uhid5 detached
>> uhid6 detached
>> uhid7 detached
>> uhid8 detached
>> uhidev5 detached
>> uhidev3 at uhub5 port 3 configuration 1 interface 0 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev3: iclass 3/1
>> ukbd1 at uhidev3: 8 variable keys, 6 key codes
>> wskbd2 at ukbd1 mux 1
>> wskbd2: connecting to wsdisplay0
>> uhidev4 at uhub5 port 3 configuration 1 interface 1 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev4: iclass 3/1, 8 report ids
>> ums1 at uhidev4 reportid 2: 16 buttons, Z and W dir
>> wsmouse1 at ums1 mux 0
>> uhid2 at uhidev4 reportid 3: input=4, output=0, feature=0
>> uhid3 at uhidev4 reportid 4: input=1, output=0, feature=0
>> uhid4 at uhidev4 reportid 8: input=1, output=0, feature=0
>> uhidev5 at uhub5 port 3 configuration 1 interface 2 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev5: iclass 3/0, 33 report ids
>> uhid5 at uhidev5 reportid 16: input=6, output=6, feature=0
>> uhid6 at uhidev5 reportid 17: input=19, output=19, feature=0
>> uhid7 at uhidev5 reportid 32: input=14, output=14, feature=0
>> uhid8 at uhidev5 reportid 33: input=31, output=31, feature=0
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhub0: device problem, disabling port 4
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhub0: port 4, set config 0 at addr 3 failed
>> uhub0: device problem, disabling port 4
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> uhidev6 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev6: iclass 3/1, 1 report id
>> ums2 at uhidev6 reportid 1: 3 buttons, Z dir
>> wsmouse2 at ums2 mux 0
>> wsmouse2 detached
>> ums2 detached
>> uhidev6 detached
>> usbd_free_xfer: xfer=0xfffffd843e83aa50 not free
>> usbd_free_xfer: xfer=0xfffffd843e83a780 not free
>> syncing disks... done
>> r
>> OpenBSD 6.5 (GENERIC.MP) #7: Wed Nov 20 23:21:48 MST 2019
>>    
>t...@syspatch-65-amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>> real mem = 16033533952 (15290MB)
>> avail mem = 15537963008 (14818MB)
>> mpath0 at root
>> scsibus0 at mpath0: 256 targets
>> mainbus0 at root
>> bios0 at mainbus0: SMBIOS rev. 2.8 @ 0xebf90 (49 entries)
>> bios0: vendor American Megatrends Inc. version "204" date 11/20/2014
>> bios0: ASUSTeK COMPUTER INC. X550ZA
>> acpi0 at bios0: rev 2
>> acpi0: sleep states S0 S3 S4 S5
>> acpi0: tables DSDT FACP APIC FPDT ECDT MCFG MSDM HPET UEFI SSDT SSDT
>CRAT SSDT SSDT SSDT SSDT
>> acpi0: wakeup devices LOM_(S4) SBAZ(S4) ECIR(S4) OHC1(S4) EHC1(S4)
>OHC2(S4) EHC2(S4) OHC3(S4) EHC3(S4) OHC4(S4) XHC0(S4) XHC1(S4) ODD8(S3)
>GLAN(S4) LID_(S5) SLPB(S4)
>> acpitimer0 at acpi0: 3579545 Hz, 32 bits
>> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
>> cpu0 at mainbus0: apid 16 (boot processor)
>> cpu0: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2496.41 MHz,
>15-30-01
>> cpu0:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu0: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu0: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu0: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu0: smt 0, core 0, package 0
>> mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
>> cpu0: apic clock running at 99MHz
>> cpu0: mwait min=64, max=64, IBE
>> cpu1 at mainbus0: apid 17 (application processor)
>> cpu1: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2495.34 MHz,
>15-30-01
>> cpu1:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu1: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu1: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu1: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu1: smt 1, core 0, package 0
>> cpu2 at mainbus0: apid 18 (application processor)
>> cpu2: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2495.34 MHz,
>15-30-01
>> cpu2:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu2: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu2: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu2: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu2: smt 0, core 1, package 0
>> cpu3 at mainbus0: apid 19 (application processor)
>> cpu3: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2495.34 MHz,
>15-30-01
>> cpu3:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu3: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu3: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu3: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu3: smt 1, core 1, package 0
>> ioapic0 at mainbus0: apid 0 pa 0xfec00000, version 21, 24 pins
>> ioapic1 at mainbus0: apid 1 pa 0xfec01000, version 21, 32 pins
>> acpiec0 at acpi0
>> acpimcfg0 at acpi0
>> acpimcfg0: addr 0xe0000000, bus 0-255
>> acpihpet0 at acpi0: 14318180 Hz
>> acpiprt0 at acpi0: bus 0 (PCI0)
>> acpiprt1 at acpi0: bus -1 (PB21)
>> acpiprt2 at acpi0: bus -1 (PB22)
>> acpiprt3 at acpi0: bus -1 (PB31)
>> acpiprt4 at acpi0: bus -1 (PB32)
>> acpiprt5 at acpi0: bus -1 (PB33)
>> acpiprt6 at acpi0: bus -1 (PB34)
>> acpiprt7 at acpi0: bus 2 (PE20)
>> acpiprt8 at acpi0: bus -1 (PE21)
>> acpiprt9 at acpi0: bus 3 (PE22)
>> acpiprt10 at acpi0: bus -1 (PE23)
>> acpicpu0 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpicpu1 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpicpu2 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpicpu3 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpitz0 at acpi0: critical temperature is 103 degC
>> acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
>> acpicmos0 at acpi0
>> "AMDC003" at acpi0 not configured
>> acpibat0 at acpi0: BAT0 model "X550E30" serial    type LIon oem "OEM"
>> acpiac0 at acpi0: AC unit online
>> acpibtn0 at acpi0: PWRB
>> acpibtn1 at acpi0: LID_
>> "ATK4001" at acpi0 not configured
>> "PNP0C14" at acpi0 not configured
>> acpibtn2 at acpi0: SLPB
>> "PNP0C14" at acpi0 not configured
>> cpu0: 2496 MHz: speeds: 2500 2300 2100 1700 1400 MHz
>> pci0 at mainbus0 bus 0
>> pchb0 at pci0 dev 0 function 0 "AMD AMD64 15h Root Complex" rev 0x00
>> radeondrm0 at pci0 dev 1 function 0 "ATI Kaveri Radeon R6" rev 0x00
>> drm0 at radeondrm0
>> radeondrm0: msi
>> azalia0 at pci0 dev 1 function 1 "ATI Kaveri HD Audio" rev 0x00: msi
>> azalia0: no supported codecs
>> pchb1 at pci0 dev 2 function 0 "AMD AMD64 15h PCIE" rev 0x00
>> pchb2 at pci0 dev 3 function 0 "AMD AMD64 15h PCIE" rev 0x00
>> pchb3 at pci0 dev 4 function 0 "AMD AMD64 15h PCIE" rev 0x00
>> xhci0 at pci0 dev 16 function 0 "AMD Bolton xHCI" rev 0x09: msi, xHCI
>1.0
>> usb0 at xhci0: USB revision 3.0
>> uhub0 at usb0 configuration 1 interface 0 "AMD xHCI root hub" rev
>3.00/1.00 addr 1
>> ahci0 at pci0 dev 17 function 0 "AMD Hudson-2 SATA" rev 0x40: msi,
>AHCI 1.3
>> ahci0: port 0: 6.0Gb/s
>> ahci0: port 2: 1.5Gb/s
>> scsibus1 at ahci0: 32 targets
>> sd0 at scsibus1 targ 0 lun 0: <ATA, TOSHIBA MQ01ABD1, AX0R> SCSI3
>0/direct fixed naa.5000039614b041b8
>> sd0: 953869MB, 512 bytes/sector, 1953525168 sectors
>> cd0 at scsibus1 targ 2 lun 0: <MATSHITA, DVD-RAM UJ8G6, 1.00> ATAPI
>5/cdrom removable
>> ohci0 at pci0 dev 18 function 0 "AMD Hudson-2 USB" rev 0x11: apic 0
>int 18, version 1.0, legacy support
>> ehci0 at pci0 dev 18 function 2 "AMD Hudson-2 USB2" rev 0x11: apic 0
>int 17
>> usb1 at ehci0: USB revision 2.0
>> uhub1 at usb1 configuration 1 interface 0 "AMD EHCI root hub" rev
>2.00/1.00 addr 1
>> ohci1 at pci0 dev 19 function 0 "AMD Hudson-2 USB" rev 0x11: apic 0
>int 18, version 1.0, legacy support
>> ehci1 at pci0 dev 19 function 2 "AMD Hudson-2 USB2" rev 0x11: apic 0
>int 17
>> usb2 at ehci1: USB revision 2.0
>> uhub2 at usb2 configuration 1 interface 0 "AMD EHCI root hub" rev
>2.00/1.00 addr 1
>> piixpm0 at pci0 dev 20 function 0 "AMD Hudson-2 SMBus" rev 0x16:
>polling
>> iic0 at piixpm0
>> spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
>> spdmem1 at iic0 addr 0x51: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
>> azalia1 at pci0 dev 20 function 2 "AMD Hudson-2 HD Audio" rev 0x01:
>msi
>> azalia1: codecs: Realtek ALC269
>> audio0 at azalia1
>> pcib0 at pci0 dev 20 function 3 "AMD Hudson-2 LPC" rev 0x11
>> ppb0 at pci0 dev 20 function 4 "AMD Hudson-2 PCI" rev 0x40
>> pci1 at ppb0 bus 1
>> sdhc0 at pci0 dev 20 function 7 "AMD Hudson-2 SD Host Controller" rev
>0x00: apic 0 int 16
>> sdhc0: SDHC 2.0, 50 MHz base clock
>> sdmmc0 at sdhc0: 4-bit, sd high-speed, mmc high-speed, dma
>> ppb1 at pci0 dev 21 function 0 "AMD Hudson-2 PCIE" rev 0x00
>> pci2 at ppb1 bus 2
>> ppb2 at pci0 dev 21 function 2 "AMD Hudson-2 PCIE" rev 0x00
>> pci3 at ppb2 bus 3
>> re0 at pci3 dev 0 function 0 "Realtek 8168" rev 0x0c: RTL8168G/8111G
>(0x4c00), msi, address 1c:b7:2c:22:fb:c9
>> rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
>> pchb4 at pci0 dev 24 function 0 "AMD AMD64 15h Link Cfg" rev 0x00
>> pchb5 at pci0 dev 24 function 1 "AMD AMD64 15h Address Map" rev 0x00
>> pchb6 at pci0 dev 24 function 2 "AMD AMD64 15h DRAM Cfg" rev 0x00
>> pchb7 at pci0 dev 24 function 3 "AMD AMD64 15h Misc Cfg" rev 0x00
>> pchb8 at pci0 dev 24 function 4 "AMD AMD64 15h CPU Power" rev 0x00
>> pchb9 at pci0 dev 24 function 5 "AMD AMD64 15h Misc Cfg" rev 0x00
>> usb3 at ohci0: USB revision 1.0
>> uhub3 at usb3 configuration 1 interface 0 "AMD OHCI root hub" rev
>1.00/1.00 addr 1
>> usb4 at ohci1: USB revision 1.0
>> uhub4 at usb4 configuration 1 interface 0 "AMD OHCI root hub" rev
>1.00/1.00 addr 1
>> isa0 at pcib0
>> isadma0 at isa0
>> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
>> pckbd0 at pckbc0 (kbd slot)
>> wskbd0 at pckbd0: console keyboard
>> pcppi0 at isa0 port 0x61
>> spkr0 at pcppi0
>> vmm0 at mainbus0: SVM/RVI
>> efifb at mainbus0 not configured
>> uhidev0 at uhub0 port 3 configuration 1 interface 0 "KINESIS
>FREESTYLE KB800 KB800 Kinesis Freestyle" rev 1.10/1.22 addr 2
>> uhidev0: iclass 3/1
>> ukbd0 at uhidev0: 8 variable keys, 6 key codes
>> wskbd1 at ukbd0 mux 1
>> uhidev1 at uhub0 port 3 configuration 1 interface 1 "KINESIS
>FREESTYLE KB800 KB800 Kinesis Freestyle" rev 1.10/1.22 addr 2
>> uhidev1: iclass 3/0, 3 report ids
>> uhid0 at uhidev1 reportid 2: input=1, output=0, feature=0
>> uhid1 at uhidev1 reportid 3: input=2, output=0, feature=0
>> uhidev2 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev2: iclass 3/1, 1 report id
>> ums0 at uhidev2 reportid 1: 3 buttons, Z dir
>> wsmouse0 at ums0 mux 0
>> uhub5 at uhub1 port 1 configuration 1 interface 0 "GenesysLogic
>USB2.0 Hub" rev 2.00/92.24 addr 2
>> uhub5: device problem, disabling port 1
>> uhidev3 at uhub5 port 3 configuration 1 interface 0 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev3: iclass 3/1
>> ukbd1 at uhidev3: 8 variable keys, 6 key codes
>> wskbd2 at ukbd1 mux 1
>> uhidev4 at uhub5 port 3 configuration 1 interface 1 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev4: iclass 3/1, 8 report ids
>> ums1 at uhidev4 reportid 2: 16 buttons, Z and W dir
>> wsmouse1 at ums1 mux 0
>> uhid2 at uhidev4 reportid 3: input=4, output=0, feature=0
>> uhid3 at uhidev4 reportid 4: input=1, output=0, feature=0
>> uhid4 at uhidev4 reportid 8: input=1, output=0, feature=0
>> uhidev5 at uhub5 port 3 configuration 1 interface 2 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev5: iclass 3/0, 33 report ids
>> uhid5 at uhidev5 reportid 16: input=6, output=6, feature=0
>> uhid6 at uhidev5 reportid 17: input=19, output=19, feature=0
>> uhid7 at uhidev5 reportid 32: input=14, output=14, feature=0
>> uhid8 at uhidev5 reportid 33: input=31, output=31, feature=0
>> uvideo0 at uhub2 port 4 configuration 1 interface 0 "Chicony
>Electronics USB2.0 VGA UVC WebCam" rev 2.00/99.16 addr 2
>> video0 at uvideo0
>> vscsi0 at root
>> scsibus2 at vscsi0: 256 targets
>> softraid0 at root
>> scsibus3 at softraid0: 256 targets
>> sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2
>0/direct fixed
>> sd1: 953868MB, 512 bytes/sector, 1953523553 sectors
>> root on sd1a (6759d2c493c65bb1.a) swap on sd1b dump on sd1b
>> initializing kernel modesetting (KAVERI 0x1002:0x130D 0x1043:0x17FD).
>> radeondrm0: 1366x768, 32bpp
>> wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using
>wskbd0
>> wskbd1: connecting to wsdisplay0
>> wskbd2: connecting to wsdisplay0
>> wsdisplay0: screen 1-5 added (std, vt100 emulation)
>> wsmouse0 detached
>> ums0 detached
>> uhidev2 detached
>> iridium[77335]: pledge "rpath", syscall 5
>> syncing disks... done
>> r
>> OpenBSD 6.5 (GENERIC.MP) #7: Wed Nov 20 23:21:48 MST 2019
>>    
>t...@syspatch-65-amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
>> real mem = 16033533952 (15290MB)
>> avail mem = 15537971200 (14818MB)
>> mpath0 at root
>> scsibus0 at mpath0: 256 targets
>> mainbus0 at root
>> bios0 at mainbus0: SMBIOS rev. 2.8 @ 0xebf90 (49 entries)
>> bios0: vendor American Megatrends Inc. version "204" date 11/20/2014
>> bios0: ASUSTeK COMPUTER INC. X550ZA
>> acpi0 at bios0: rev 2
>> acpi0: sleep states S0 S3 S4 S5
>> acpi0: tables DSDT FACP APIC FPDT ECDT MCFG MSDM HPET UEFI SSDT SSDT
>CRAT SSDT SSDT SSDT SSDT
>> acpi0: wakeup devices LOM_(S4) SBAZ(S4) ECIR(S4) OHC1(S4) EHC1(S4)
>OHC2(S4) EHC2(S4) OHC3(S4) EHC3(S4) OHC4(S4) XHC0(S4) XHC1(S4) ODD8(S3)
>GLAN(S4) LID_(S5) SLPB(S4)
>> acpitimer0 at acpi0: 3579545 Hz, 32 bits
>> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
>> cpu0 at mainbus0: apid 16 (boot processor)
>> cpu0: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2496.40 MHz,
>15-30-01
>> cpu0:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu0: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu0: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu0: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu0: smt 0, core 0, package 0
>> mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
>> cpu0: apic clock running at 99MHz
>> cpu0: mwait min=64, max=64, IBE
>> cpu1 at mainbus0: apid 17 (application processor)
>> cpu1: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2495.34 MHz,
>15-30-01
>> cpu1:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu1: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu1: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu1: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu1: smt 1, core 0, package 0
>> cpu2 at mainbus0: apid 18 (application processor)
>> cpu2: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2495.34 MHz,
>15-30-01
>> cpu2:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu2: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu2: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu2: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu2: smt 0, core 1, package 0
>> cpu3 at mainbus0: apid 19 (application processor)
>> cpu3: AMD A10-7400P Radeon R6, 10 Compute Cores 4C+6G, 2495.34 MHz,
>15-30-01
>> cpu3:
>FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,POPCNT,AES,XSAVE,AVX,F16C,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,ITSC,FSGSBASE,BMI1,XSAVEOPT
>> cpu3: 96KB 64b/line 3-way I-cache, 16KB 64b/line 4-way D-cache, 2MB
>64b/line 16-way L2 cache
>> cpu3: ITLB 48 4KB entries fully associative, 24 4MB entries fully
>associative
>> cpu3: DTLB 64 4KB entries fully associative, 64 4MB entries fully
>associative
>> cpu3: smt 1, core 1, package 0
>> ioapic0 at mainbus0: apid 0 pa 0xfec00000, version 21, 24 pins
>> ioapic1 at mainbus0: apid 1 pa 0xfec01000, version 21, 32 pins
>> acpiec0 at acpi0
>> acpimcfg0 at acpi0
>> acpimcfg0: addr 0xe0000000, bus 0-255
>> acpihpet0 at acpi0: 14318180 Hz
>> acpiprt0 at acpi0: bus 0 (PCI0)
>> acpiprt1 at acpi0: bus -1 (PB21)
>> acpiprt2 at acpi0: bus -1 (PB22)
>> acpiprt3 at acpi0: bus -1 (PB31)
>> acpiprt4 at acpi0: bus -1 (PB32)
>> acpiprt5 at acpi0: bus -1 (PB33)
>> acpiprt6 at acpi0: bus -1 (PB34)
>> acpiprt7 at acpi0: bus 2 (PE20)
>> acpiprt8 at acpi0: bus -1 (PE21)
>> acpiprt9 at acpi0: bus 3 (PE22)
>> acpiprt10 at acpi0: bus -1 (PE23)
>> acpicpu0 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpicpu1 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpicpu2 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpicpu3 at acpi0: C2(0@400 io@0x1771), C1(@1 halt!), PSS
>> acpitz0 at acpi0: critical temperature is 103 degC
>> acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
>> acpicmos0 at acpi0
>> "AMDC003" at acpi0 not configured
>> acpibat0 at acpi0: BAT0 model "X550E30" serial    type LIon oem "OEM"
>> acpiac0 at acpi0: AC unit online
>> acpibtn0 at acpi0: PWRB
>> acpibtn1 at acpi0: LID_
>> "ATK4001" at acpi0 not configured
>> "PNP0C14" at acpi0 not configured
>> acpibtn2 at acpi0: SLPB
>> "PNP0C14" at acpi0 not configured
>> cpu0: 2496 MHz: speeds: 2500 2300 2100 1700 1400 MHz
>> pci0 at mainbus0 bus 0
>> pchb0 at pci0 dev 0 function 0 "AMD AMD64 15h Root Complex" rev 0x00
>> radeondrm0 at pci0 dev 1 function 0 "ATI Kaveri Radeon R6" rev 0x00
>> drm0 at radeondrm0
>> radeondrm0: msi
>> azalia0 at pci0 dev 1 function 1 "ATI Kaveri HD Audio" rev 0x00: msi
>> azalia0: no supported codecs
>> pchb1 at pci0 dev 2 function 0 "AMD AMD64 15h PCIE" rev 0x00
>> pchb2 at pci0 dev 3 function 0 "AMD AMD64 15h PCIE" rev 0x00
>> pchb3 at pci0 dev 4 function 0 "AMD AMD64 15h PCIE" rev 0x00
>> xhci0 at pci0 dev 16 function 0 "AMD Bolton xHCI" rev 0x09: msi, xHCI
>1.0
>> usb0 at xhci0: USB revision 3.0
>> uhub0 at usb0 configuration 1 interface 0 "AMD xHCI root hub" rev
>3.00/1.00 addr 1
>> ahci0 at pci0 dev 17 function 0 "AMD Hudson-2 SATA" rev 0x40: msi,
>AHCI 1.3
>> ahci0: port 0: 6.0Gb/s
>> ahci0: port 2: 1.5Gb/s
>> scsibus1 at ahci0: 32 targets
>> sd0 at scsibus1 targ 0 lun 0: <ATA, TOSHIBA MQ01ABD1, AX0R> SCSI3
>0/direct fixed naa.5000039614b041b8
>> sd0: 953869MB, 512 bytes/sector, 1953525168 sectors
>> cd0 at scsibus1 targ 2 lun 0: <MATSHITA, DVD-RAM UJ8G6, 1.00> ATAPI
>5/cdrom removable
>> ohci0 at pci0 dev 18 function 0 "AMD Hudson-2 USB" rev 0x11: apic 0
>int 18, version 1.0, legacy support
>> ehci0 at pci0 dev 18 function 2 "AMD Hudson-2 USB2" rev 0x11: apic 0
>int 17
>> usb1 at ehci0: USB revision 2.0
>> uhub1 at usb1 configuration 1 interface 0 "AMD EHCI root hub" rev
>2.00/1.00 addr 1
>> ohci1 at pci0 dev 19 function 0 "AMD Hudson-2 USB" rev 0x11: apic 0
>int 18, version 1.0, legacy support
>> ehci1 at pci0 dev 19 function 2 "AMD Hudson-2 USB2" rev 0x11: apic 0
>int 17
>> usb2 at ehci1: USB revision 2.0
>> uhub2 at usb2 configuration 1 interface 0 "AMD EHCI root hub" rev
>2.00/1.00 addr 1
>> piixpm0 at pci0 dev 20 function 0 "AMD Hudson-2 SMBus" rev 0x16:
>polling
>> iic0 at piixpm0
>> spdmem0 at iic0 addr 0x50: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
>> spdmem1 at iic0 addr 0x51: 8GB DDR3 SDRAM PC3-12800 SO-DIMM
>> azalia1 at pci0 dev 20 function 2 "AMD Hudson-2 HD Audio" rev 0x01:
>msi
>> azalia1: codecs: Realtek ALC269
>> audio0 at azalia1
>> pcib0 at pci0 dev 20 function 3 "AMD Hudson-2 LPC" rev 0x11
>> ppb0 at pci0 dev 20 function 4 "AMD Hudson-2 PCI" rev 0x40
>> pci1 at ppb0 bus 1
>> sdhc0 at pci0 dev 20 function 7 "AMD Hudson-2 SD Host Controller" rev
>0x00: apic 0 int 16
>> sdhc0: SDHC 2.0, 50 MHz base clock
>> sdmmc0 at sdhc0: 4-bit, sd high-speed, mmc high-speed, dma
>> ppb1 at pci0 dev 21 function 0 "AMD Hudson-2 PCIE" rev 0x00
>> pci2 at ppb1 bus 2
>> ppb2 at pci0 dev 21 function 2 "AMD Hudson-2 PCIE" rev 0x00
>> pci3 at ppb2 bus 3
>> re0 at pci3 dev 0 function 0 "Realtek 8168" rev 0x0c: RTL8168G/8111G
>(0x4c00), msi, address 1c:b7:2c:22:fb:c9
>> rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
>> pchb4 at pci0 dev 24 function 0 "AMD AMD64 15h Link Cfg" rev 0x00
>> pchb5 at pci0 dev 24 function 1 "AMD AMD64 15h Address Map" rev 0x00
>> pchb6 at pci0 dev 24 function 2 "AMD AMD64 15h DRAM Cfg" rev 0x00
>> pchb7 at pci0 dev 24 function 3 "AMD AMD64 15h Misc Cfg" rev 0x00
>> pchb8 at pci0 dev 24 function 4 "AMD AMD64 15h CPU Power" rev 0x00
>> pchb9 at pci0 dev 24 function 5 "AMD AMD64 15h Misc Cfg" rev 0x00
>> usb3 at ohci0: USB revision 1.0
>> uhub3 at usb3 configuration 1 interface 0 "AMD OHCI root hub" rev
>1.00/1.00 addr 1
>> usb4 at ohci1: USB revision 1.0
>> uhub4 at usb4 configuration 1 interface 0 "AMD OHCI root hub" rev
>1.00/1.00 addr 1
>> isa0 at pcib0
>> isadma0 at isa0
>> pckbc0 at isa0 port 0x60/5 irq 1 irq 12
>> pckbd0 at pckbc0 (kbd slot)
>> wskbd0 at pckbd0: console keyboard
>> pcppi0 at isa0 port 0x61
>> spkr0 at pcppi0
>> vmm0 at mainbus0: SVM/RVI
>> efifb at mainbus0 not configured
>> uhidev0 at uhub0 port 3 configuration 1 interface 0 "KINESIS
>FREESTYLE KB800 KB800 Kinesis Freestyle" rev 1.10/1.22 addr 2
>> uhidev0: iclass 3/1
>> ukbd0 at uhidev0: 8 variable keys, 6 key codes
>> wskbd1 at ukbd0 mux 1
>> uhidev1 at uhub0 port 3 configuration 1 interface 1 "KINESIS
>FREESTYLE KB800 KB800 Kinesis Freestyle" rev 1.10/1.22 addr 2
>> uhidev1: iclass 3/0, 3 report ids
>> uhid0 at uhidev1 reportid 2: input=1, output=0, feature=0
>> uhid1 at uhidev1 reportid 3: input=2, output=0, feature=0
>> uhub5 at uhub1 port 1 configuration 1 interface 0 "GenesysLogic
>USB2.0 Hub" rev 2.00/92.24 addr 2
>> uhub5: device problem, disabling port 1
>> uhidev2 at uhub5 port 3 configuration 1 interface 0 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev2: iclass 3/1
>> ukbd1 at uhidev2: 8 variable keys, 6 key codes
>> wskbd2 at ukbd1 mux 1
>> uhidev3 at uhub5 port 3 configuration 1 interface 1 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev3: iclass 3/1, 8 report ids
>> ums0 at uhidev3 reportid 2: 16 buttons, Z and W dir
>> wsmouse0 at ums0 mux 0
>> uhid2 at uhidev3 reportid 3: input=4, output=0, feature=0
>> uhid3 at uhidev3 reportid 4: input=1, output=0, feature=0
>> uhid4 at uhidev3 reportid 8: input=1, output=0, feature=0
>> uhidev4 at uhub5 port 3 configuration 1 interface 2 "Logitech USB
>Receiver" rev 2.00/12.07 addr 3
>> uhidev4: iclass 3/0, 33 report ids
>> uhid5 at uhidev4 reportid 16: input=6, output=6, feature=0
>> uhid6 at uhidev4 reportid 17: input=19, output=19, feature=0
>> uhid7 at uhidev4 reportid 32: input=14, output=14, feature=0
>> uhid8 at uhidev4 reportid 33: input=31, output=31, feature=0
>> uvideo0 at uhub2 port 4 configuration 1 interface 0 "Chicony
>Electronics USB2.0 VGA UVC WebCam" rev 2.00/99.16 addr 2
>> video0 at uvideo0
>> vscsi0 at root
>> scsibus2 at vscsi0: 256 targets
>> softraid0 at root
>> scsibus3 at softraid0: 256 targets
>> sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2
>0/direct fixed
>> sd1: 953868MB, 512 bytes/sector, 1953523553 sectors
>> root on sd1a (6759d2c493c65bb1.a) swap on sd1b dump on sd1b
>> initializing kernel modesetting (KAVERI 0x1002:0x130D 0x1043:0x17FD).
>> radeondrm0: 1366x768, 32bpp
>> wsdisplay0 at radeondrm0 mux 1: console (std, vt100 emulation), using
>wskbd0
>> wskbd1: connecting to wsdisplay0
>> wskbd2: connecting to wsdisplay0
>> wsdisplay0: screen 1-5 added (std, vt100 emulation)
>> uhidev5 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev5: iclass 3/1, 1 report id
>> ums1 at uhidev5 reportid 1: 3 buttons, Z dir
>> wsmouse1 at ums1 mux 0
>> wsmouse1 detached
>> ums1 detached
>> uhidev5 detached
>> uhidev5 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev5: iclass 3/1, 1 report id
>> ums1 at uhidev5 reportid 1: 3 buttons, Z dir
>> wsmouse1 at ums1 mux 0
>> wsmouse1 detached
>> ums1 detached
>> uhidev5 detached
>> uhidev5 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev5: iclass 3/1, 1 report id
>> ums1 at uhidev5 reportid 1: 3 buttons, Z dir
>> wsmouse1 at ums1 mux 0
>> iridium[2535]: pledge "rpath", syscall 5
>> iridium[32155]: pledge "rpath", syscall 5
>> iridium[15840]: pledge "rpath", syscall 5
>> wsmouse1 detached
>> ums1 detached
>> uhidev5 detached
>> uhidev5 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev5: iclass 3/1, 1 report id
>> ums1 at uhidev5 reportid 1: 3 buttons, Z dir
>> wsmouse1 at ums1 mux 0
>> wsmouse1 detached
>> ums1 detached
>> uhidev5 detached
>> uhidev5 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev5: iclass 3/1, 1 report id
>> ums1 at uhidev5 reportid 1: 3 buttons, Z dir
>> wsmouse1 at ums1 mux 0
>> wsmouse1 detached
>> ums1 detached
>> uhidev5 detached
>> uhidev5 at uhub0 port 4 configuration 1 interface 0 "vendor 0x0000
>USB OPTICAL MOUSE" rev 1.10/1.00 addr 3
>> uhidev5: iclass 3/1, 1 report id
>> ums1 at uhidev5 reportid 1: 3 buttons, Z dir
>> wsmouse1 at ums1 mux 0
>> wsmouse1 detached
>> ums1 detached
>> uhidev5 detached
>> iridium[36082]: pledge "rpath", syscall 5
>> iridium[58077]: pledge "rpath", syscall 5
>> iridium[16854]: pledge "rpath", syscall 5
>> uhidev5 at u

Hi  Luke,

Have you tried to reuse  ssh connections.
In linux you can use something like this:
ControlMaster auto 
ControlPath ~/.ssh/sockets/%r@%h-%p
ControlPersist 600

I guess it's  still valid for openBSD.

Best Regards,
Strahil Nikolov

Reply via email to