In case someone is interested in the problem, the files are here:
teste.m2v is 3.2MB and
teste.mpg is 3.5MB

----------  Original Message  ----------

Date: Wednesday 15 November 2006 16:02

Well, it's a problem hard to describe and hard to believe.

Where it all began:
1) Capturing in kino from (old) VHS tape.
VHS -> composite video/audio -> DV Camcorder -> firewire -> kino

2) Sliced out unwanted material (beginning and ending of tape, etc) and saved
as smil. Size is 0:40:46.177

3) Encoded the above generated smil, like this:
smil2yuv $1.smil | mpeg2enc -H -v 0 -n n -I 1 -a 2 -b $2 -f 8 -q 4 -4 1 -2
1 -r 32 -g 6 -G 18 -B 260 -K tmpgenc -o vid_$1.m2v > log1_$1.txt 2>
smil2wav $1.smil | mp2enc -e -o aud_$1.mp2 >> log1_$1.txt 2>> log2_$1.txt
mplex -f 8 -R -V -o $1.mpg vid_$1.m2v aud_$1.mp2 >> log1_$1.txt 2>>

4) Opened in qdvdauthor, but size was only 0:32:28 (I think my qdvdauthor
 uses mplayer).

5) Opened mpg in xine, same result. Opened in kino, by importing the mpg
 file, same result (32 min).

* long long long time testing *

I decided to slice the dv file to only 170 frames to do the tests, of course.
The only hint I have came from importing the mpg file to kino.
It uses mencoder and ffmpeg to convert mpg to dv, so I picked up his script
and joined after encoding, like this:

cat teste.smil
smil2yuv teste.smil | mpeg2enc -H -f 8 -o teste.m2v
smil2wav teste.smil | mp2enc -e -o teste.mp2
mplex -f 8 -R -V -o teste.mpg teste.m2v teste.mp2
mencoder -o /home/delio/teste.mpg.avi -oac pcm -ovc lavc
 /home/delio/teste.mpg lavinfo teste.mpg.avi
results of this script is attached as mpeg_script_results.txt

During mencoder run, this is what happens:
1 duplicate frame(s)!
Pos:   0.7s     22f ( 9%)   0fps Trem:   0min   3mb  A-V:0.070 [0:1536]
Skipping frame!
Pos:   1.5s     47f ( 9%)   0fps Trem:   0min   3mb  A-V:0.067 [60:1536]
Skipping frame!
Pos:   5.6s    170f (100%)  51fps Trem:   0min   2mb  A-V:0.016 [1811:1536]
Flushing video frames

Out of lavinfo (that should be 170 frames):

6) More information when importing files to kino:
Importing file teste.mpg results in 166 frames
Importing intermediate video file teste.m2v results in 168 frames

7) After much of testing, one last tool in my system: Avidemux!

8) Opened in Avidemux, great! 0:40:46.179 !

The question is: What is wrong? It seems xine and mplayer can not deal with
this mpeg stream. Is it some kind of outdated libs?

* Information: System and Versions *

model name      : AMD Athlon(TM) XP1800+
stepping        : 2
cpu MHz         : 1544.717
cache size      : 256 KB

Main memory: 256 MB DDR

OS (Fedora Core 4): 2.6.17-1.2142_FC4

mjpegtools: 1.9.0 (2.2.6)

xine: v0.99.4.

mencoder: 1.0pre7-4.0.2

dvdauthor: version 0.6.11.

qdvdauthor: 0.1.0

avidemux: 2.1.2


Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
Mjpeg-users mailing list

Reply via email to