Actually it's OK:  The name "coll" is defined a couple lines up by the "A 
collection adapter {@code collectArguments(mh, 0, coll)} ...", and the term 
"filter" is persistently applied to it. So I think it is intelligible as 
posted.  — John

On Oct 4, 2013, at 11:34 AM, John Rose <john.r.r...@oracle.com> wrote:

> Yikes; good catch.  I used javac -Xdoclint to find a couple typos in @param 
> also.  — John
> 
> On Oct 4, 2013, at 11:17 AM, Christian Thalinger 
> <christian.thalin...@oracle.com> wrote:
> 
>> You have renamed "coll" to "filter" but the documentation still references 
>> "coll" in multiple places, e.g.:
>> 
>> +     * If the filter method handle {@code coll} consumes one argument and 
>> produces
>> +     * a non-void result, then {@code collectArguments(mh, N, coll)}
>> +     * is equivalent to {@code filterArguments(mh, N, coll)}.
> 
> _______________________________________________
> mlvm-dev mailing list
> mlvm-dev@openjdk.java.net
> http://mail.openjdk.java.net/mailman/listinfo/mlvm-dev

_______________________________________________
mlvm-dev mailing list
mlvm-dev@openjdk.java.net
http://mail.openjdk.java.net/mailman/listinfo/mlvm-dev

Reply via email to