Dan,

I'll try 1.6.12 and file the bug as you suggest.

Thanks for the help,
John

On Fri, Feb 2, 2018 at 10:24 AM, Dan Williams <d...@redhat.com> wrote:
> On Fri, 2018-02-02 at 09:33 -0600, John Chiasson wrote:
>> Hi,
>>
>> I'm having little success with this modem under ubuntu 17.10 x64.  I
>> did manage to get it to connect once while running both managers in
>> foreground debug mode, but am unable to connect running as services.
>> Debug logs are attached.  Are there any guides for running as
>> services
>> while in debug, and retrieving logs from journalctl?  Also, I've read
>> the 4G - 3G handoff can drop connection.  Is there any guide for
>> forcing a 3G connection?
>
> That was around the 2011/2012 timeframe due to the integration of
> Verizon's EVDO and LTE networks with eHRPD.  Also the 1.48 firmware
> version that I think your device is running already supposedly had
> fixes for handoff.
>
> Anyway, I think you're running into a ModemManager bug that is fixed in
> 1.6.12 by this commit:
>
> 6c1c3405c68bc86c873f0bae6595c3917358f530
> bearer-qmi: fix connect with libqmi lower than 1.18
>
> The connect process in your logs just stops after setting the IP family
> preference and does not continue to the actual connect step.
>
> I would file an Ubuntu Launchpad bug against ModemManager to see if
> they can either (a) backport this commit or (b) just update the MM
> version to 1.6.12 or later.  Not really Ubuntu's fault as this was only
> fixed about a month ago.
>
> Dan
_______________________________________________
ModemManager-devel mailing list
ModemManager-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/modemmanager-devel

Reply via email to