Hello Ran,

           Yes, it's ok to not inline if the compiler has problems with it.


            It seems like you have problems with the installation path. The 
mono executable has a default path included in itself where it expects to have 
been installed, along with the assemblies. (in your case, this path is 
/usr/local). You can either change this path by passing --prefix="path" to 
autogen (this is also where mono will end up if calling make install), or you 
can just pass the environment variable MONO_PATH to point to the corlib and 
other assemblies.


Vlad


Sent from Outlook<http://aka.ms/weboutlook>

________________________________
From: Mono-devel-list <mono-devel-list-boun...@lists.dot.net> on behalf of Ran 
Shalit <ransha...@gmail.com>
Sent: Thursday, September 22, 2016 1:06:17 PM
To: mono-devel-list@lists.dot.net; mono-l...@lists.dot.net
Subject: [Mono-dev] Q: "The assembly mscorlib.dll was not found"

Hello,

I am trying to get mono with armv5. I've made some progress on this
issue as following.

I am using 2009q3 for arm , with version 4.0.0

I've configured it as following with autogen.sh:
CXX=arm-none-linux-gnueabi-g++ CC=arm-none-linux-gnueabi-gcc
CFLAGS="-march=armv5te -mtune=arm926ej-s -mfloat-abi=soft"
./autogen.sh --host=arm-none-linux-gnueabi --disable-mcs-build

On build I got only one error :
In file included from sgen-major-copy-object.h:33,
                 from sgen-marksweep.c:857:
sgen-copy-object.h: In function 'copy_object_no_checks':
sgen-copy-object.h:41: sorry, unimplemented: inlining failed in call
to 'par_copy_object_no_checks': function body not available
sgen-copy-object.h:95: sorry, unimplemented: called from here


>>> I had removed "MONO_ALWAYS_INLINE" for the function decleration - Is that 
>>> OK ?


Yet, I still get the same error on exectuable.
# ./mono /home/modem/Elbit/Elbit_test/Elbit.Jdss.TestConsoleMonoNoUI.exe
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the
`/usr/local/lib/mono/4.5/mscorlib.dll' directory.

After "make" , and "make install" , I deployed it as following:
I copied all /usr folder into some folder in target (I don't have
access to /usr/local/ which is read-only filesystem, but to
/home/usr/local .... )

Thank you for any suggestion,
Ran
_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-devel-list
_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-devel-list

Reply via email to