Hello,

I managed to cross build and run successfuly simple application arm
(using 3.8.0 mono version without any modifications).
On running a simple hello world it works fine. But then running the
required application throws the following error.
I should also note that I copied the class library from host in order
for it to works becuase the deplyment (make install) is missing all
these dlls.
I also see that the same source version 3.8.0 on my PC , I manage to
run the application without this exception (in PC x86), so I suspect
that it is related to the fact that the same source code is cross
build to arm (armv5) maybe.


This is the log when running the application:

# mono /home/modem/Elbit/Elbit_test/Elbit.Jdss.TestConsoleMonoNoUI.exe
Elbit.Jdss.TestConsoleMonoNoUI

My IP is 192.168.7.2
Running on Unix
Running with the Mono VM
.NET Framework Assemblies Path:
file:///home/modem/local/lib/mono/4.5/mscorlib.dll

Unhandled Exception:
[0xbeb0be6c]

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException:
An exception was thrown by the type initializer for
System.Xml.Serialization.XmlSerializer --->
System.Configuration.ConfigurationErrorsException: Error Initializing
the configuration system. --->
System.Configuration.ConfigurationErrorsException: Unrecognized
configuration section <startup>
(/home/modem/Elbit/Elbit_test/Elbit.Jdss.TestConsoleMonoNoUI.exe.config
line 3)
  at System.Configuration.ConfigInfo.ThrowException (System.String
text, System.Xml.XmlReader reader) [0x00000] in <filename unknown>:0
  at System.Configuration.SectionGroupInfo.ReadContent
(System.Xml.XmlReader reader, System.Configuration.Configuration
config, Boolean overrideAllowed, Boolean root) [0x00000] in <filename
unknown>:0
  at System.Configuration.SectionGroupInfo.ReadRootData
(System.Xml.XmlReader reader, System.Configuration.Configuration
config, Boolean overrideAllowed) [0x00000] in <filename unknown>:0
  at System.Configuration.Configuration.ReadConfigFile
(System.Xml.XmlReader reader, System.String fileName) [0x00000] in
<filename unknown>:0
  at System.Configuration.Configuration.Load () [0x00000] in <filename
unknown>:0
  at System.Configuration.Configuration.Init (IConfigSystem system,
System.String configPath, System.Configuration.Configuration parent)
[0x00000] in <filename unknown>:0
  at System.Configuration.Configuration..ctor
(System.Configuration.InternalConfigurationSystem system,
System.String locationSubPath) [0x00000] in <filename unknown>:0
  at System.Configuration.InternalConfigurationFactory.Create
(System.Type typeConfigHost, System.Object[]
hostInitConfigurationParams) [0x00000] in <filename unknown>:0

I see that there is bug report about XmlSerializer, but this same
version works in PC (x86) without issues, so I am not sure what it
means.

Best Regards,
Ran
_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-devel-list

Reply via email to