Full output of './mono/mini/mono -V' here: http://pastebin.com/xZw3qhVD

On Oct 12, 2016 12:12 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:

> Since I don't have a working mcs installed, I'm using the snapshots
> available from the download site here: http://download.mono-project.
> com/sources/mono/
>
> Here's the output of ./mono/mini/mono -V from my build tree:
>
> ./mono/mini/mono -V
>
> Mono JIT compiler version 4.7.0 (Nightly 4.7.0.593/4e441ec
>
> On Oct 11, 2016 10:06 AM, "Ludovic Henry" <luhe...@microsoft.com> wrote:
>
>> Hi Cyd,
>>
>>
>>
>> Which mono commit are you based on? It seems like the managed
>> System.Threading.InternalThread is missing the “last” field.
>>
>>
>>
>> Thank you,
>>
>> Ludovic
>>
>>
>>
>> *From: *Mono-devel-list <mono-devel-list-boun...@lists.dot.net> on
>> behalf of Cyd Haselton <chasel...@gmail.com>
>> *Date: *Tuesday, 11 October 2016 at 15:55
>> *To: *Miguel de Icaza <mig...@microsoft.com>
>> *Cc: *mono-devel <mono-devel-l...@lists.ximian.com>
>> *Subject: *Re: [Mono-dev] Problem with mcs build
>>
>>
>>
>> Full backtrace log posted here: http://pastebin.com/ncbnBWxh
>> <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fpastebin.com%2FncbnBWxh&data=01%7C01%7Cluhenry%40microsoft.com%7Cc158682791b74d1bb8f808d3f1de56fe%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=F%2B7H5U0vVuuUafzUWRFv9faFPA8TBkdVSbWLjGPX%2BEk%3D&reserved=0>
>>
>> Any ideas welcome.
>>
>>
>>
>> On Oct 9, 2016 6:22 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Finally got back to this. Added gdb to the mono-wrapper script and got
>> the following:
>>
>> Temporary breakpoint 1, main (argc=24, argv=0x7ffffff188) at
>> ./main.c:213                   213             mono_build_date =
>> build_date;                                               (gdb)
>> stepi
>> [New LWP 6866]
>>
>>                                                        Thread 1 "Main"
>> received signal SIGSEGV, Segmentation fault.
>> 0x0000005593890e48 in mono_field_get_offset (field=0x0) at
>> class.c:9610                     9610            return field->offset;
>>
>>
>>
>> On Sep 23, 2016 8:01 AM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Will do. Termux has a gdb package available.
>>
>> You don't see anything obvious from the errors/warnings I've already
>> posted?
>>
>>
>>
>> On Sep 23, 2016 1:48 AM, "Miguel de Icaza" <mig...@microsoft.com> wrote:
>>
>> Ah, that explains a lot.
>>
>>
>>
>> At this point, your best bet will be to debug the runtime and figure out
>> what is breaking for you on your setup.
>>
>>
>>
>> Miguel.
>>
>>
>>
>> *From: *Cyd Haselton <chasel...@gmail.com>
>> *Date: *Thursday, September 22, 2016 at 8:00 PM
>> *To: *Miguel de Icaza <mig...@microsoft.com>, mono-devel <
>> mono-devel-l...@lists.ximian.com>
>> *Subject: *Re: [Mono-dev] Problem with mcs build
>>
>>
>>
>> It's Android.  Specifically Termux on Android.  The required
>> libraries…with the exception of X11…have been installed via Termux's 'apt
>> install' or built on-device.
>>
>> I realize that on-build Android is not supported; I'm just looking for
>> help on this and/or previous errors/warnings I've posted.
>>
>>
>>
>> On Sep 22, 2016 4:57 PM, "Miguel de Icaza" <mig...@microsoft.com> wrote:
>>
>> Hello Cyd,
>>
>>
>>
>> I do not recall, what platform is this?
>>
>>
>>
>> Miguel.
>>
>>
>>
>> *From: *Cyd Haselton <chasel...@gmail.com>
>> *Date: *Thursday, September 22, 2016 at 5:20 PM
>> *To: *mono-devel <mono-devel-l...@lists.ximian.com>
>> *Cc: *Alexander Köplinger <alk...@microsoft.com>, Miguel de Icaza <
>> mig...@microsoft.com>
>> *Subject: *Re: [Mono-dev] Problem with mcs build
>>
>>
>>
>> Additional info:
>>
>> Just to see what would happen…and because I've just about given up hope
>> on hearing back from anyone on this issue…I navigated to
>> $(topbuilddir)/mcs/mcs and ran make.  Results were:
>>
>> make[1]: Entering directory '/data/data/com.termux/files/p
>> kg/ps/mono-4.7.0/mcs/mcs'         MCS     [net_4_x]
>> mcs.exe
>>
>>
>> ============================================================
>> =====                           Got a SIGSEGV while executing native
>> code. This usually indicates                           a fatal error in
>> the mono runtime or one of the native libraries
>> used by your application.
>> =================================================================
>>
>>
>>
>> On Sep 21, 2016 4:36 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> While waiting for a response I deleted the build tree, downloaded another
>> tarball from the site, unpacked  and re-ran 'autogen.sh && make'
>>
>> The build errored out at the same place, with the same prior warnings.
>>
>> At this point I'm at a loss. Any input would be welcome.
>>
>>
>>
>> On Sep 21, 2016 7:10 AM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Pinging again. Any ideas as to where I should be looking for the problem?
>>
>> FYI, while waiting I dumped the help for the bootstrap compiler for clues
>> and found this:
>>
>> <snip>
>> -reference:ALIAS=A   Imports metadata using specified extern alias
>> (short: -r)
>> -sdk:VERSION         Specifies SDK version of referenced
>> assemblies                                              VERSION can be
>> one of: 2, 4, 4.5 (default) or a custom value
>> <snip>
>>
>> The command line right before the two warnings and build failure is this:
>>
>> MONO_PATH="./../class/lib/monolite:$MONO_PATH"
>> /data/data/com.termux/files/pkg/ps/mono-4.6.0/runtime/mono-wrapper
>> ./../class/lib/monolite/basic.exe /codepage:65001 -sdk:4.5 -r:System.dll
>> -r:System.Core.dll -r:System.Xml.dll 
>> -d:STATIC,NO_SYMBOL_WRITER,NO_AUTHENTICODE
>> -d:MONO_FEATURE_THREAD_ABORT -d:MONO_FEATURE_PROCESS_START  -d:NET_4_0
>> -d:NET_4_5 -d:MONO -d:BOOTSTRAP_BASIC -nowarn:1699
>> -lib:./../class/lib/basic   -target:exe -out:../class/lib/basic/basic.exe
>> cs-parser.cs  @mcs.exe.sources
>>
>> Should the "-r" params include paths to those files?
>>
>>
>>
>> On Sep 20, 2016 1:06 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Any thoughts?  Or is this another stale build?
>>
>>
>>
>> On Tue, Sep 20, 2016 at 8:47 AM, Cyd Haselton <chasel...@gmail.com>
>> wrote:
>>
>> Additionally I Googled the warning that appears before the build error:
>> warning CS8001: SDK path could not be resolved
>>
>> The first two hits mention that the cause is usually due to a missing
>> System.Drawing.dll, but it is present in the build tree under
>> ./external/binary-reference-assemblies/vX.x, where 'X.x' is  2.0, 4.0
>> and 4.5.
>>
>> Googling the Unhandled Exception error brings up hits from the Unity
>> forums and not much else.
>>
>>
>>
>> On Sep 20, 2016 7:13 AM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> While waiting for a response I ran 'make clean' then 'make V=1 2>&1 | tee
>> mono_build_log.'
>>
>> I've posted the results here: http://pastebin.com/s3gHQQdg
>> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fpastebin.com%2fs3gHQQdg&data=02%7c01%7cmiguel%40microsoft.com%7ca1b5f222d26545b7167e08d3e32e504e%7c72f988bf86f141af91ab2d7cd011db47%7c1%7c0%7c636101760471232175&sdata=WWsVl5M6DDzgpPJUex%2fNxLd45fheb5qo%2bfK44E%2f0HAw%3d>
>>
>>
>>
>> On Sep 19, 2016 6:02 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Should I run make clean and try again? Or is there something wrong with
>> the mcs/mcs Makefile?
>>
>>
>>
>> On Sep 19, 2016 4:33 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Downloaded latest tarball, ran autogen.sh. It failed at the start of the
>> mcs build because the mono-wrapper, mono and mcs scripts had #!/bin/sh
>> instead of the correct path.  Fixed that, re-ran make and got the  error
>> from my first email
>>
>> Pastebin here: http://pastebin.com/gdAcRKN6
>> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fpastebin.com%2fgdAcRKN6&data=02%7c01%7cmiguel%40microsoft.com%7ca1b5f222d26545b7167e08d3e32e504e%7c72f988bf86f141af91ab2d7cd011db47%7c1%7c0%7c636101760471232175&sdata=mcrm%2fPJkR74ogA%2bQTfZ89TRtpLMhf7vhTIXi%2bOJq5o8%3d>
>>
>>
>>
>> On Sep 19, 2016 2:23 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
>>
>> Er…I *can't* do that because the instructions say that building from git
>> assumes mono is installed.
>>
>> I'll download the latest tarball…
>>
>>
>>
>>
>>
>>
_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-devel-list

Reply via email to