On Thu, 2003-02-20 at 07:59, Charles Iliya Krempeaux wrote: > Hello, > > On Wed, 2003-02-19 at 22:42, Mike Kestner wrote: > > On Thu, 2003-02-20 at 00:07, Charles Iliya Krempeaux wrote: > > [...] > > > > The important thing to focus on is this line: > > > > > > this.DeleteEvent += new > > > GtkSharp.DeleteEventHandler(delete_event); > > > > There is no need to use the "this" keyword anywhere in this class. Doing > > so is just extra typing. > > I wanted to use the "this" keyword for clarity. (I find it helps > beginners alot. A beginner will not know what a "DeleteEvent" is. > But with the "this" keyword there, they can immediately tell that > it is a property of the class they are using.)
I have to second Mike's comment here. You can always describe where DeleteEvent comes from bellow the source code or in a comment. I think using this.<Member> is going rather to confuse beginners. Cheers Radek _______________________________________________ Mono-docs-list maillist - [EMAIL PROTECTED] http://lists.ximian.com/mailman/listinfo/mono-docs-list
