Hi All !

Addendum.

Just removed the apt-pinning and install succeeds!

$ mono --version
Mono JIT compiler version 4.6.2 (Stable 4.6.2.16/ac9e222 Tue Jan  3 11:48:26 
UTC 2017)

Now, have to look further and read more. Ether my pin'ning
was wrong or my understanding of apt arguments or the
xamarin package ... ;-)

Thanks so far!
Manfred


> -----Original Message-----
> From: Mono-list [mailto:mono-list-boun...@lists.dot.net] On Behalf Of
> web...@manfbraun.de
> Sent: Friday, January 13, 2017 10:08 AM
> To: 'Alexander Köplinger'; 'William Ivanski'
> Cc: mono-list@lists.dot.net
> Subject: Re: [Mono-list] Install on debian fails
> 
> Hi !
> 
> Thanks for your investigation!
> That is exactly, what I've done (and wrote initially).
> The mono-xamarin.list contains two entries, the second
> one is that '.. libjpeg62...'.
> 
> But, in opposite to William, who used:
> >apt-get install mono-complete
> I used
> >apt-get install -t wheezy mono-complete
> 
> I've pin'ned my system to 900 to not accidentally
> install something form the backports repository,
> which I need for some rare things. So my prefs are:
> Package: *
> Pin: release n=jessie
> Pin-Priority: 900
> 
> I came to the "-t" argument, because I use this way,
> if I install from backports.
> 
> Now, I tried again with just plain:
> >apt-get install mono-complete
> 
> This succeeds, but installed mono 3.2.8 ....
> 
> No I have further headdache. It is a zfs dataset,
> I restored the last snapshot and now, it can wether
> mount nor unmound (just opened a help call there) ...
> Just cannot boot this time.
> 
> Anyway, I would like to hear opinions about this.
> Thanks,
> Manfred
> 
> 
> 
> > -----Original Message-----
> > From: Alexander Köplinger [mailto:alk...@microsoft.com]
> > Sent: Friday, January 13, 2017 3:29 AM
> > To: web...@manfbraun.de; William Ivanski
> > Cc: mono-list@lists.dot.net
> > Subject: Re: [Mono-list] Install on debian fails
> >
> > For Debian 8 (Jessie) you need to add a second separate repository for
> > libdiplus as mentioned here: http://www.mono-project.com/docs/getting-
> > started/install/linux/#libgdiplus-debian-80-and-later-not-ubuntu
> >
> > > echo "deb http://download.mono-project.com/repo/debian wheezy-
> libjpeg62-
> > compat main" | sudo tee -a /etc/apt/sources.list.d/mono-xamarin.list
> >
> > I just tried this in a clean Docker container and it works.
> >
> > - Alex
> >
> > > On 13 Jan 2017, at 03:17, William Ivanski <william.ivan...@gmail.com>
> > wrote:
> > >
> > > Here is what I did to install mono on Debian Jessie:
> > >
> > > apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys
> > 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
> > > echo "deb http://download.mono-project.com/repo/debian wheezy main" |
> > sudo tee /etc/apt/sources.list.d/mono-xamarin.list
> > > apt-get update
> > > aptitude install mono-complete
> > > aptitude install mono-xsp4
> > > aptitude install monodevelop
> > >
> > > Can't tell you exactly what version was installed at the time, but it
> > worked. I always keep the system up-to-date, so right now I'm running
> mono
> > 4.6.2, from Xamarin repo.
> > >
> > > Em sex, 13 de jan de 2017 às 00:10, <web...@manfbraun.de> escreveu:
> > > Hi !
> > >
> > >
> > >
> > > Oh, yeah, sorry - I am on debian jessie (8.6), with kernel 3.16.
> > >
> > > I had several other attempts to install mono from the xamarin
> > >
> > > repo (and I reported them here - but, sad to say, got no answer).
> > >
> > >
> > >
> > > On official repo, there is mono 3.2.8 and nothing in backports.
> > >
> > > On the initial machine, I gave up and I am missing features. But
> > >
> > > this one is completely new - although, it's a LXC VM. Exactly this
> > >
> > > should help me to come to a workaround.
> > >
> > >
> > >
> > > In the basic setup, there is absolut nothing about mono. Should
> > >
> > > I install from original repositiory first and the upgrade to
> > >
> > > the version in the xamarin repository?
> > >
> > >
> > >
> > > Thanks,
> > >
> > > Manfred
> > >
> > >
> > >
> > >
> > >
> > > From: William Ivanski [mailto:william.ivan...@gmail.com]
> > > Sent: Friday, January 13, 2017 2:37 AM
> > > To: web...@manfbraun.de; mono-list@lists.dot.net
> > > Subject: Re: [Mono-list] Install on debian fails
> > >
> > >
> > >
> > > Are you using Debian 7 (Wheezy) or 8 (Jessie) ? If you are on Debian
> 7,
> > could you please try on Debian 8?
> > >
> > >
> > >
> > > Em qui, 12 de jan de 2017 às 21:43, <web...@manfbraun.de> escreveu:
> > >
> > > Hello !
> > >
> > > I just tried to install mono-complete and followed exactly
> > > the instructions here:
> > >
> > > http://www.mono-project.com/docs/getting-started/install/linux/
> > >
> > > But the setup failed:
> > >
> > > + apt-get install -t wheezy mono-complete
> > > Reading package lists... Done
> > > Building dependency tree
> > > Reading state information... Done
> > > Some packages could not be installed. This may mean that you have
> > > requested an impossible situation or if you are using the unstable
> > > distribution that some required packages have not yet been created
> > > or been moved out of Incoming.
> > > The following information may help to resolve the situation:
> > >
> > > The following packages have unmet dependencies:
> > >  mono-complete : Depends: mono-devel (= 4.6.2.16-0xamarin1) but it is
> > not
> > > going to be installed
> > >                  Depends: mono-4.0-service (= 4.6.2.16-0xamarin1) but
> it
> > is
> > > not going to be installed
> > >                  Depends: monodoc-manual (= 4.6.2.16-0xamarin1) but it
> > is
> > > not going to be installed
> > >                  Depends: libmono-cil-dev (= 4.6.2.16-0xamarin1) but
> it
> > is
> > > not going to be installed
> > > E: Unable to correct problems, you have held broken packages.
> > >
> > > This was a fresh machine setup, so why could this happen?
> > > >From my experience, sad to say, this is an ongoing problem.
> > >
> > > Could please have someone an eye on this?
> > > Or are there newer instructions?
> > >
> > > Thanks,
> > > Manfred
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > Mono-list maillist  -  Mono-list@lists.dot.net
> > > http://lists.dot.net/mailman/listinfo/mono-list
> > >
> > > --
> > >
> > > William Ivanski - Microsoft MVP
> > >
> > > --
> > > William Ivanski - Microsoft MVP
> > >
> > > _______________________________________________
> > > Mono-list maillist  -  Mono-list@lists.dot.net
> > >
> >
> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Flists.dot.
> > net%2Fmailman%2Flistinfo%2Fmono-
> >
> list&data=02%7C01%7Calkpli%40microsoft.com%7C32566060938f4b2124b208d43b5a5
> >
> 038%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636198706478295752&sdata=
> > sy9ycUigqUhAD5DUG5A8vTvkuwPK%2Fr60kKi6VqRYD%2FM%3D&reserved=0
> 
> 
> 
> _______________________________________________
> Mono-list maillist  -  Mono-list@lists.dot.net
> http://lists.dot.net/mailman/listinfo/mono-list


_______________________________________________
Mono-list maillist  -  Mono-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-list

Reply via email to