Dear MPB/MEEP community,

 As shown in the Meep tutorial “Visualizing 3d Structures”, mayavi package
is recommended to use for 3d visualization (
https://meep.readthedocs.io/en/latest/Python_Tutorials/Basics/#visualizing-3d-structures
).

When I tried to install mayavi using “conda install vtk”, “conda install
pyqt=5”, and “conda install mayavi” under the meep environment, I got after
“conda install mayavi”,

*Solving environment: failed:*

*UnsatisfiableError: The following specifications were found to be in
conflict:*

*  - mayavi*

*  - pymeep -> *[track_features=nomkl]*

*  - pymeep -> openblas[version='>=0.2.20,<0.2.21.0a0'] ->
openblas-devel[version='>=0.2.20,<0.2.21.0a0'] -> blas=[build=openblas]*

*Use "conda info <package>" to see the dependencies for each package.*

Is anyone able to share insights on how I could possibly resolve the
version conflict issue here? Thank you!

Yang
_______________________________________________
mpb-discuss mailing list
mpb-discuss@ab-initio.mit.edu
http://ab-initio.mit.edu/cgi-bin/mailman/listinfo/mpb-discuss

Reply via email to