I am having some trouble using the rpt functionality of the CPUX. While
attempting to assemble some code for the msp430fr5969 I was surprised
with this error:

repeat count cannot be used with rrux

In response to:
rpt r15 { rrux.w r6

This was surprising because the example in slau367 for rrux shows it
being used with a repeat. After some fiddling around I was able to
generate code that worked but I had to bang it in using .word
directives. objdump produced:

rpt r15 { rrcx.w        r6

Which is almost but not quite correct because it ignores the little
detail of the extension word having the ZC bit set. I tried doing the
same thing using the rrux.w instruction but for some reason that seems
to be ignoring the repeat count and always shifted by one bit.

Which brings up another problem. Not only is the use of rpt not
documented for the GNU assembler, there isn't any hint of how to set the
ZC bit in the extension word.

slau367 is a bit thin in describing the repeat feature as well. It
barely gets a mention in the description of the extension word and
appears a few times in examples. Other than that there is nothing.

David W. Schultz
Returned for Regrooving

Site24x7 APM Insight: Get Deep Visibility into Application Performance
APM + Mobile APM + RUM: Monitor 3 App instances at just $35/Month
Monitor end-to-end web transactions and take corrective actions now
Troubleshoot faster and improve end-user experience. Signup Now!
Mspgcc-users mailing list

Reply via email to