Odd thing....

we've been in the process of upgrading from an ooold set of plugins, to a 
new one, on solaris

we have some "very large" filesystems we want to monitor.

the old 1.3.1 plugin version of "check_disk" worked fine.

the newer ones did not, at one point.
(I'm dealing with 1.4.13 of the plugins)

The older one calls "df". The newer one attempts to use system calls to 
figure it out "the hard way".

Odd thing is... SOMETIMES, it compiles correctly.
Sometimes, it does not.

I have not yet figured out the magic that makes it compile "correctly".
However, when it didnt, I brute-forced the issue a bit, by defining.


and then it seems to work.

Odd thing is that a more recent test compile, showed
in config.log, and that resulted in a check_disk that worked correctly on 
large files.

Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
Nagios-users mailing list
::: Please include Nagios version, plugin version (-v) and OS when reporting 
any issue. 
::: Messages without supporting info will risk being sent to /dev/null

Reply via email to