Dear all,

i have just commited a change addression all var name 
changes that maurizio brought up.
The most common use-case of the variable "new" is of the form

    Tcl_CreateHashEntry(&table, value, &new);

The tcl source code uses new typically "isNew" instead of 
new, so we loose nothing
on readability etc. by making the same change. i would have 
objected to change
the variable name to e.g. "mm_new" just to silence a certain 
compiler, but in terms
of readability, "isNew" looks actually better.
Similarly, tcl avoids the variable name "bool",

    Tcl_GetBooleanFromObj(interp, objv[3], &boolValue)

etc. So, i have put together a single changeset to address 
these issues.
I hope, i found all cases. If anyone objects, feel free to 
undo this change.

With this committed, there are still the typcast changes to 
address,
and to look closer of the few other changes of maurizio (so 
far, i have
not come across the other K&R style files in the naviserver 
sources).

-gustaf neumann


------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_sfd2d_oct
_______________________________________________
naviserver-devel mailing list
naviserver-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/naviserver-devel

Reply via email to