Hi Roger,

Thanks for the review , please find the updated webrev(http://cr.openjdk.java.net/~vtewari/8145635/webrev0.6/index.html).

Thanks,

Vyom


On Tuesday 17 October 2017 06:35 AM, Roger Riggs wrote:
Hi Vyom,

A few suggestions:

PlainDatagramSocketImpl.java:
 - line 95/96:  I think you can use just forEach, the order version is not necessary.     The code will be a bit more readable if the .filter and .forEach are on a new line and don't wrap.
    You can also remove the extra "(" and ")

 - line 87-94: these are confusing and imply some implicit resetting of the option.
 - use @since 10
- 209/268: the native setQuickAck method should use boolean as its argument to enable/disable
  Since enable is a boolean; it does not need "== true'

LinuxSocketOptions.java/c:
  - 52: setQuickAck0 should use boolean for the 2nd argument; (The native code already does)

Thanks, Roger


On 10/15/17 11:58 PM, vyom tewari wrote:
Hi Chris,

Thanks for review. Please find the latest webrev(http://cr.openjdk.java.net/~vtewari/8145635/webrev0.5/index.html).

Thanks,

Vyom



Reply via email to