Hi Alan,

I have renamed loopbackAddress() into loopbackSocketAddress(), thanks
for the suggestion!

http://cr.openjdk.java.net/~dfuchs/webrev_8231506/webrev.01

I also made a small modification to store the local port
in a final field in UnreferencedMulticastSockets::Server constructor
(one of my tests run got a NPE calling `Server::getPort())

best regards,

-- daniel

On 26/09/2019 16:43, Alan Bateman wrote:


On 26/09/2019 15:16, Daniel Fuchs wrote:
Hi,

Please find below a patch for:

https://bugs.openjdk.java.net/browse/JDK-8231506
8231506: Fix some instabilities in a few networking tests

webrev:
http://cr.openjdk.java.net/~dfuchs/webrev_8231506/webrev.00/

In SocketImplCombinations, the update to testNewSocket2 looks good. My fault that it didn't originally use the loopback address. I assume the rest of the changes to the test aren't really needed as the changes are to tests that don't involve a connection (the tests are mostly checking that accept fails due to a SocketImpl mismatch). No objection to the changes but if you do include them then loopbackAddress should probably be renamed to loopbackSocketAddress to avoid confusing readers (as it returns a SocketAddress rather than the InetAddress for the loopback address).

-Alan

Reply via email to