On Sun, 17 Sep 2023 23:21:23 GMT, Mark Sheppard <mshep...@openjdk.org> wrote:
> on further reflection, wrt method name, an overloaded getByAddress(String > literalAddress) method is most appropriate I agree, and it should have both variants, getByAddtess(String literalAddress) throws UHE getByAdress(String hostname, String literalAddress) throws UHE In order to produce resolved addresses as well. (The UHE is a bit strange but the preexisting method used it for a reason for invalid address arrays, I guess) ------------- PR Comment: https://git.openjdk.org/jdk/pull/15775#issuecomment-1722599828