Em 21-09-2016 07:18, David Laight escreveu:
From: Marcelo Ricardo Leitner
Sent: 20 September 2016 21:24
To something more meaningful these days, specially because this is
working on packet headers or lengths and which are not tied to any CPU
arch but to the protocol itself.
So, WORD_TRUNC becomes SCTP_TRUNC4 and WORD_ROUND becomes SCTP_ALIGN4.
/* Round an int up to the next multiple of 4. */
-#define WORD_ROUND(s) (((s)+3)&~3)
+#define SCTP_ALIGN4(s) (((s)+3)&~3)
SCTP_PAD4() might be a better name.
Right. Will post a v3 with it. Thanks