On Tue, May 16, 2017 at 2:34 PM, David Miller <da...@davemloft.net> wrote:
> From: Cong Wang <xiyou.wangc...@gmail.com>
> Date: Tue, 16 May 2017 13:51:30 -0700
>
>> On Tue, May 16, 2017 at 10:27 AM, Jiri Pirko <j...@resnulli.us> wrote:
>>> +int tcf_block_get(struct tcf_block **p_block,
>>> +                 struct tcf_proto __rcu **p_filter_chain)
>>> +{
>>> +       struct tcf_block *block = kzalloc(sizeof(*block), GFP_KERNEL);
>>> +
>>> +       if (!block)
>>> +               return -ENOMEM;
>>> +       block->p_filter_chain = p_filter_chain;
>>> +       *p_block = block;
>>> +       return 0;
>>> +}
>>> +EXPORT_SYMBOL(tcf_block_get);
>>
>>
>> XXX_get() is usually for refcnt'ing, here you only allocate
>> a block, so please rename it to tcf_block_alloc().
>
> Later in the series he adds refcounting to these objects.
>
> He explained this to Jamal too.

I have read all patches, unless I miss something, block itself
is not refcn'ted, only chains are, so it makes no sense to get
a block, right?

Reply via email to