From: Rasmus Villemoes <li...@rasmusvillemoes.dk> Date: Tue, 21 Nov 2017 01:34:37 +0100
> dev_alloc_name_ns and dev_get_valid_name now do exactly the same > thing. Let's expose this functionality as dev_alloc_name_ns > (obviously, a core function like this won't return an invalid > name...). > > Signed-off-by: Rasmus Villemoes <li...@rasmusvillemoes.dk> If you're going to keep one of the routines, keep the one with the simpler and smaller name, "dev_get_valid_name".