On Wed, 2018-03-07 at 15:41 -0500, Doug Ledford wrote:
> On Wed, 2018-03-07 at 15:31 -0500, David Miller wrote:
> > From: Saeed Mahameed <sae...@mellanox.com>
> > Date: Tue,  6 Mar 2018 22:35:03 -0800
> > 
> > > This series includes shared code updates for mlx5 core driver for both
> > > netdev and rdma subsystems.  This series should be pulled to both
> > > trees so we can continue netdev and rdma specific submissions separately.
> > > 
> > > For more information please see tag log below.
> > > 
> > > The series doesn't cause any conflict with the latest mlx5 rc fixes.
> > > 
> > > v1->v2:
> > >   - Drop sparse fixes patch
> > >   - Updated commit message of "net/mlx5: Add has_tag to mlx5_flow_act"
> > >   - Add const to  static mlx5_flow_cmd structs where needed.
> > 
> > Pulled, thanks Saeed.
> Thanks, pulled here as well.

Just FYI,

My .config might have been in an unreasonable state (I had jumped from
for-next to for-rc, built a kernel which ran a make oldconfig, then
jumped back to for-next and tried to build with this series applied but
without making any changes to the .config file), but I got a build
error.  My .config had both innova and the new ipsec accelerator turned
off or something like that, and I got this error:

  CC [M]  drivers/net/ethernet/mellanox/mlx5/core/en_main.o
drivers/net/ethernet/mellanox/mlx5/core/fs_core.c: In function
drivers/net/ethernet/mellanox/mlx5/core/fs_core.c:2645:6: error:
implicit declaration of function ‘mlx5_accel_ipsec_device_caps’; did you
mean ‘mlx5_accel_ipsec_cleanup’? [-Werror=implicit-function-declaration]
  if (mlx5_accel_ipsec_device_caps(steering->dev) &
  CC [M]  drivers/net/ethernet/silan/sc92031.o
  CC [M]  drivers/w1/slaves/w1_smem.o
  CC [M]  drivers/net/ethernet/mellanox/mlx5/core/en_common.o
  CC [M]  drivers/net/ethernet/sfc/falcon/nic.o
drivers/net/ethernet/mellanox/mlx5/core/fs_core.c:2646:6: error:
‘MLX5_ACCEL_IPSEC_DEVICE’ undeclared (first use in this function); did
you mean ‘__MLX5_ACCEL_IPSEC_H__’?
drivers/net/ethernet/mellanox/mlx5/core/fs_core.c:2646:6: note: each
undeclared identifier is reported only once for each function it appears
  CC [M]  drivers/w1/w1.o

Running make config and enabling innova support and ipsec accelerator
support fixed it.

Doug Ledford <dledf...@redhat.com>
    GPG KeyID: B826A3330E572FDD
    Key fingerprint = AE6B 1BDA 122B 23B4 265B  1274 B826 A333 0E57 2FDD

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to