These patches remove the term slave from the iproute2 visible
command line, documentation, and variable naming.

This needs doing despite the fact it will cause cosmetic
changes to visible outputs.

Stephen Hemminger (5):
  bpf: replace slave with sub
  bridge: remove slave from comments and message
  testsuite: replace Enslave with Insert
  ip: replace slave_kind
  ip: rename slave to subport

 bridge/vlan.c                                 |  4 +-
 ip/Makefile                                   |  4 +-
 ip/ip_common.h                                |  2 +-
 ip/ipaddress.c                                | 44 ++++++++--------
 ip/iplink.c                                   |  4 +-
 ip/iplink_bond.c                              | 44 ++++++++--------
 ...ink_bond_slave.c => iplink_bond_subport.c} | 48 ++++++++---------
 ...bridge_slave.c => iplink_bridge_subport.c} | 52 +++++++++----------
 ip/iplink_hsr.c                               | 20 +++----
 ip/iplink_team.c                              | 10 ++--
 ip/iplink_vrf.c                               |  8 +--
 ip/iplink_xstats.c                            |  2 +-
 lib/bpf.c                                     |  8 +--
 lib/namespace.c                               |  2 +-
 man/man8/ip-address.8.in                      |  8 +--
 man/man8/ip-link.8.in                         | 26 +++++-----
 man/man8/ip-nexthop.8                         |  2 +-
 testsuite/tests/bridge/vlan/show.t            |  4 +-
 testsuite/tests/bridge/vlan/tunnelshow.t      |  4 +-
 19 files changed, 148 insertions(+), 148 deletions(-)
 rename ip/{iplink_bond_slave.c => iplink_bond_subport.c} (74%)
 rename ip/{iplink_bridge_slave.c => iplink_bridge_subport.c} (88%)

-- 
2.26.2

Reply via email to