On Tue, Mar 06, 2018 at 02:39:26PM +1100, Duncan Roe wrote:
> To get libnftnl/flowtable.h nftables now needs a newer libftnl than the latest
> release. This temporary check advises the unwary of that.
> This test can be removed once libnftnl 1.0.10 is released (and tested for).
> 
> Signed-off-by: Duncan Roe <duncan_...@optusnet.com.au>
> ---
>  configure.ac | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/configure.ac b/configure.ac
> index 2d0b1b9..9c719a0 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -77,6 +77,7 @@ AM_COND_IF([BUILD_PDF], [
>  
>  PKG_CHECK_MODULES([LIBMNL], [libmnl >= 1.0.3])
>  PKG_CHECK_MODULES([LIBNFTNL], [libnftnl >= 1.0.9])
> +AC_CHECK_HEADER(libnftnl/flowtable.h, , [AC_MSG_ERROR([Can't find 
> libnftnl/flowtable.h -- need libnftnl git 2018-01-29 or newer])])

Thanks Duncan.

I have updated libnftnl version and updated nft dependencies, so we
can avoid breaking compilation now. I think it's fine if we just bump
versions numbers now, no need to wait for release.
--
To unsubscribe from this list: send the line "unsubscribe netfilter-devel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to