On Tue, Jan 17, 2017 at 5:30 PM, Vadim Kochan <vadi...@gmail.com> wrote: > Hi Tobias, > > Just some thoughts from me regarding this commit, if the below > can make a sense. > > In case if list_head (now cds_list_head) will be used by other modules > and lets imagine that we will get rid of liburcu dependency (for example > if we can make flowtop single threaded) then we will need to have copy-paste > cds_* API from urcu or have a wrappers for it, so may be it is better > to have generic name w/o cds_ prefix ? > > Regards, > Vadim Kochan
Sorry for the noise. Well now I think that cds_ will be used for RCU like list usage, and if to use simple list_head then we will need to have local list.h to do not make dpendencies to liburcu. -- You received this message because you are subscribed to the Google Groups "netsniff-ng" group. To unsubscribe from this group and stop receiving emails from it, send an email to netsniff-ng+unsubscr...@googlegroups.com. For more options, visit https://groups.google.com/d/optout.