On 06/19/2012 10:34 PM, Niels Möller wrote: > In recent months, some new RSA functions have been added, from > suggestions and work of Nikos. I'd like to hear comments on the > interface before release. > > Do you think this looks good? I see that there's some inconsistency of > using "nettle_random_func random" vs "nettle_random_func *random", the > latter variant is the preferred form.
If this is because of me, feel free to correct it. It must have been a typo. > 3. Should I rename it to _pkcs1_signature_prefix, in order to (i) make > it more clear it's an internal function, and (ii) make applications > depending on the old behaviour break in a more predictable fashion? I'd say this is a good option. If you care about backwards compatibility then the old function could also be present. regards, Nikos _______________________________________________ nettle-bugs mailing list [email protected] http://lists.lysator.liu.se/mailman/listinfo/nettle-bugs
