Nikos Mavrogiannopoulos <n...@redhat.com> writes:

> While using that code, I realized that the CMAC128_UPDATE was misusing
> the 'data' field. In the attached patch I've renamed it to 'src' to
> avoid ambiguities.

Pushed to a branch "cmac-support", together with ChangeLog and some
cleanups:

        * cmac.h (struct cmac128): Rename, to cmac128_ctx.
        (CMAC128_CTX): Rename first member from data to ctx.

        * cmac.c: Use const void * as the type for cipher arguments.
        (block_mulx): Un-inline.
        (cmac128_set_key): Make a constant function local.

        * testsuite/cmac-test.c: Delete local typedefs.

Thanks!
/Niels

-- 
Niels Möller. PGP-encrypted email is preferred. Keyid 368C6677.
Internet email is subject to wholesale government surveillance.
_______________________________________________
nettle-bugs mailing list
nettle-bugs@lists.lysator.liu.se
http://lists.lysator.liu.se/mailman/listinfo/nettle-bugs

Reply via email to