Congratulations to the whole team for reaching the release 1.0 milestone!

I'm trying to build Unit on Gentoo Linux, and while module configs for
Python and Perl work as expected, I'm struggling with the PHP module:

  $ ./configure php --config=/usr/lib64/php7.1/bin/php-config
  configuring PHP module
  checking for PHP ... found
   + PHP SAPI: [cli fpm apache2handler]
  checking for PHP embed SAPI ... not found

Here is the content of build/autoconf.err:

configuring PHP module ...
checking for PHP ...
7.1.16
----------------------------------------
checking for PHP embed SAPI
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: 
cannot find -lphp7
collect2: error: ld returned 1 exit status
----------

        #include <php.h>
        #include <php_main.h>

        int main() {
            php_request_startup();
            return 0;
        }
----------
cc -pipe -fPIC -fvisibility=hidden -O -W -Wall -Wextra -Wno-unused-parameter 
-Wwrite-strings -Wmissing-prototypes
-Werror -g -I/usr/lib64/php7.1/include/php -I/usr/lib64/php7.1/include/php/main 
-I/usr/lib64/php7.1/include/php/TSRM
-I/usr/lib64/php7.1/include/php/Zend -I/usr/lib64/php7.1/include/php/ext 
-I/usr/lib64/php7.1/include/php/ext/date/lib -o
build/autotest build/autotest.c -lphp7
----------

A search turned up https://github.com/nginx/unit/issues/47 but I am not
sure if/how this applies to my issue and what to do next?

-Ralph
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx

Reply via email to