Nikita, how do you override the attributes?

Did you try packageOverrides like in example below?

{
     packageOverrides = pkgs: rec {
       # Make "xbmc" use the "python26" package,
       #   instead of NixPkgs default python version.
       xbmc = pkgs.xbmc.override {
         python = pkgs.python26;
       };
     };
   }

2016-10-12 22:16 GMT+01:00 Nikita Karetnikov <nik...@karetnikov.org>:

> How can I override glibc in nix-shell and use eglibc, for instance? Are
> there any examples? Do I need to override stdenv for that? Overriding the
> attributes of glibc (version and sha) directly doesn't seem to work. Could
> anyone provide an example?
> _______________________________________________
> nix-dev mailing list
> nix-dev@lists.science.uu.nl
> http://lists.science.uu.nl/mailman/listinfo/nix-dev
>



-- 
Tomasz Czyż
_______________________________________________
nix-dev mailing list
nix-dev@lists.science.uu.nl
http://lists.science.uu.nl/mailman/listinfo/nix-dev

Reply via email to