Michael Miller created ACCUMULO-4520:
----------------------------------------
Summary: Utilize Java 8 in RFile
Key: ACCUMULO-4520
URL: https://issues.apache.org/jira/browse/ACCUMULO-4520
Project: Accumulo
Issue Type: Improvement
Components: core
Affects Versions: 2.0.0
Reporter: Michael Miller
Priority: Minor
Fix For: 2.0.0
There are a few places in o.a.a.core.file.rfile.RFile where Java 8 functional
program could improve readability. There is some potential for performance
improvement as well.
One example of an improvement would be to change the 3 LocalityGroupReader
arrays (currentReaders, readers and sampleReaders) in the RFile.Reader class to
ArrayLists. This would allow use of the forEach in stream package.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)