[ 
https://issues.apache.org/jira/browse/CTAKES-445?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16115581#comment-16115581
 ] 

James Joseph Masanz commented on CTAKES-445:
--------------------------------------------

I tested out the workaround I described above using the ctakes-the-api project 
in sandbox (updated my local copy for 4.0.0) and ran  
org.apache.ctakes.clinicalpipeline.ClinicalPipelineWithUmls

Once I put the dictionary resources and necessary descriptors on my classpath, 
I was indeed able to get around the URI not hierarchical error from ctakes-lvg 
adding the complete org/apache/ctakes/lvg/data subtree to be on the classpath.

Hope you all find this workaround helpful until we come up with a better 
solution.

As I mentioned above, be aware that for ctakes-lvg to use the actual lvg 
resources, you can't just copy/extract the lvg.properties file for this 
workaround, you have to copy/extract the entire subtree, or it will create an 
empty lvg database.


> java.lang.IllegalArgumentException: URI is not hierarchical - 
> org.apache.ctakes.lvg.resource.LvgCmdApiResourceImpl.load
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: CTAKES-445
>                 URL: https://issues.apache.org/jira/browse/CTAKES-445
>             Project: cTAKES
>          Issue Type: Bug
>          Components: ctakes-lvg
>    Affects Versions: 4.0.0
>            Reporter: James Joseph Masanz
>            Assignee: James Joseph Masanz
>             Fix For: 4.0.1
>
>
> Dima reported this on the dev@ list:
> http://markmail.org/message/l6mct3btk3nb43ld
> http://mail-archives.apache.org/mod_mbox/ctakes-dev/201704.mbox/%3CF00347B9-4228-4407-B566-4EB2774B21B5%40luc.edu%3E
> When using cTAKES as maven dependency and invoking his (Dima's) program using:
> mvn exec:java 
> -Dexec.mainClass=“org.apache.ctakes.pipelines.UmlsLookupPipeline” 
> Not sure which release this originated in. reproduced it in 4.0



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to