L1yp commented on issue #15047: URL: https://github.com/apache/dubbo/issues/15047#issuecomment-2583045075
I found the cause of the problem because dubbo3 uses the nacos registry. Dual registration mode will be used, resulting in both the http port and dubbo port on a microservice being registered with nacos. Therefore, when the spring gateway obtains nacos services, after Load Balancer, it will poll and invoke these two ports, and it will be found that each time succeeds and the other fails.  -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
