mkevo commented on pull request #5175:

   > @mkevo
   > Thanks for adding the extra tests. I'm not fully convinced about the 
implemented fix, however, did you consider my comments 
Can't you just simply invoke the `DiskStoreImpl.close()` method instead of 
modifying the `DiskStoreCommandsUtils` class, as it involves way less 
modifications and we're sure it won't affect other areas of the `disk` 
management stuff?.
   I would appreciate if you can specify how to invoke this command as there is 
no method like `offlineCompact` in _DiskStoreImpl.java_ for describe command 
and others. The only change I made on `DiskStoreCommandsUtils` class that it 
also check name, not only dirs. As if name is wrong it will start thread and 
then fail without closing. Thanks!

This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:

Reply via email to