[ 
https://issues.apache.org/jira/browse/LOG4J2-2139?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16276193#comment-16276193
 ] 

Daniel Kirkdorffer commented on LOG4J2-2139:
--------------------------------------------

There is a little overlap between the two tickets, but [[email protected]] is 
correct that this one is just about renaming keys (or having the option to).

As for Kibana, this isn't an incompatibility with Kibana.  The problem is 
arising because in our situation there is a prior existence of a "source" key 
that Kibana knows to be a String, so when it tries to parse new data where 
"source" is an Object, it rejects it.  We can get around the problem by 
renaming the "source" Object - if only we could rename it.

> JSONLayout ability to rename keys in log output - particularly locationInfo 
> "source"
> ------------------------------------------------------------------------------------
>
>                 Key: LOG4J2-2139
>                 URL: https://issues.apache.org/jira/browse/LOG4J2-2139
>             Project: Log4j 2
>          Issue Type: Improvement
>          Components: Layouts
>            Reporter: Daniel Kirkdorffer
>            Priority: Minor
>              Labels: json
>
> We ran into a problem when setting {{locationInfo}} to {{true}} when 
> ingesting logs into Kibana.  The problem had to do with a conflict with 
> another existing key named {{"source"}} of type String, and the fact that 
> {{locationInfo}} produces an Object called "source".
> So it would be nice to have a way to supply a different Object name.  Perhaps 
> this could be broadened so that other key names could also be renamed?
> Maybe there is a way to do this already?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to